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COMMANDSIM FIRE: Instructor Edition lets you create realistic, interactive fire
scenarios for your tactical and strategic training. It enables you to add realistic
smoke and fire effects to your photos and videos, and integrate the simulations
seamlessly into Microsoft PowerPoint in two clicks. Achieve the exact smoke and
fire you want by dialing in more than 35 parameters, including color, wind,
velocity, plume size and orientation, etc. Two more clicks and you can publish
your results on the Web for others to see and interact with, without requiring
them to pay for extra software. Make simple views or scrolling panoramas and
360’s.

COMMANDSIM FIRE: Instructor Edition is an extendible platform that allows you
to add graphics, videos, sounds, and even fully-interactive equipment. When you
are ready for multi-player training, you can use all your scenarios developed with
the Instructor Edition inside the Department edition.

COMMANDSIM FIRE: Instructor Edition consists of the following:

o CommandSim Effects
Create realistic smoke, fire, and vapor clouds and share (or download)
effects with others

o CommandSim Transition
Smoothly and realistically transition from one effect to the next, modeling
the escalation and mitigation of the incident

o CommandSim State Manager
Allow your fire conditions to persist across different visuals, such as
walking in and around a building

o Picture Scroller
Make visuals that let viewers scan across a scene

o 360 Panorama Scroller
Make wrap-around visuals from your 360 degree pictures

o Picture Navigation
Embed navigation into your visuals to let viewers move naturally from
picture to picture

o Adobe Flash® (sold separately)
The graphics and animation engine that drives the system and lets you
develop visuals limited only by your imagination.

This manual is accessible inside Flash Help once you install COMMANDSIM FIRE:
Instructor Edition. Video tutorials are located on the distribution CD.

How Do The Elements Fit Together?
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For complete video tutorials, please visit the CommandSim Learning Community at
http://community.commandsim.com.

We have included several videos on the backup CD, as well as off of the support site
(http://www.commandsim.com/ie_support.html). If this is the first time you have used
Flash, we recommend you review our Introduction to Flash. Once you have done this, if
you want to create smoke and fire conditions on a single image or picture, you should
follow the instructions and quick start guide for CS Effects Generator. If you want to
make the smoke and fire appear as if it is coming from behind a building or through a
window, you should read the guide on using Masking. If you want to make a scrolling
panorama, which requires the viewer to pan left and right to see the whole scene (good
for teaching situational awareness), you can read about our panorama extensions.

Once you are comfortable with the basic process of placing and changing conditions,
and you want to control the escalation and mitigation of fire conditions in a single image
or picture, you should read about CS Transitions. Transitions let you change the
conditions automatically over time or when you press a keystroke. For example, you can
set your scenario such that when you press the 0 key, the conditions go to light or no
smoke, and when you press the 1 key, the conditions get progressively worse (more,
darker smoke and fire).

When you've got the hang of transitions, you are ready for the last phase—defining fire
“states”, to give you persistent fire conditions across different visuals. In other words,
you can set up what we call "states" of the scenario that arrange fire conditions into
logical groups. For example, one state may be no fire conditions, a second state may be
light smoke from one window, a third may be heavier smoke from adjoining windows,
etc. When you arrange your scenario by state, you can make your states persist
(remain) even across different visuals. For example, in separate PowerPoint slides or on
separate web pages, you could put visuals for four sides of a building, and let the viewer
move from one to the next (advance slide, or click to next slide). In any slide in which
you change the state, when you go to the next slide, that visual will show the conditions
for that state that you placed on the new slide. Your fire conditions persist across
multiple visual frames.

With the distribution CD, you will find a series of video tutorials to help you get up-to-
speed as fast as possible. If you cannot find the CD, you can visit our support web site
and view the videos online: http://www.CommandSim.com/ie_support.html.

Lastly, please remember that support is a phone call or email away. We are happy to
help you get the most from your purchase, or prospective purchase, so don't hesitate to
contact us for any reason.

All materials, text, images, and logos in this manual are copyright CommandSim 2004-10 © and
may not be duplicated electronically or in print without written permission from CommandSim.
Flash is a registered trademark of Adobe, Inc.

documentation version 1.5.6 // September 2010
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Chapter 1
Installing the Instructor edition

Commandim Fire: Instructor edition is a collection of Flash extensions that enlarge Flash's
powerful animation capabilities to support the types of training materials you want to develop as a
Fire Service instructor. To install Flash extensions, you need the Adobe Extension Manager. This
typically comes with your distribution of Flash. The easiest way to see is to look at the
CommandSim files you have downloaded (or on the distribution CD). Look for the file CSFI_v1.mxp
(depending on your viewing settings, you may not see the ".mxp"). If you have the Extension
Manager installed already, you will see the icon pictured here:

-~

<

CSFI_v1.mxp

If you do not see this icon, you do not have the Extension Manager installed so you need to get it
and install it. If you see the icon with the file, click on or skip to "Installing Extensions".

How to Learn to Build Simulations with this Software

Please visit our CommandSim Learning Community site (http://community.commandsim.com) for
detailed instructional videos, course plans, and materials.

How Do I Update Files from the Trial to the Full Version?

The trial version will allow you to use all the features of the full system, but only for 30 days. Any
simulations you make within the 30 days will work fine, but you cannot edit the smoke and fire
effects beyond the 30 days.

If you purchase the full version, you can replace the smoke from the trial edition with the smoke
from the full version and your simulations will work exactly the same, without you having to
recreate your scenarios.

Downloading and Installing the Adobe Extension Manager

The Adobe Extension Manager is a free program for managing extensions to Adobe products, such
as Flash. You must have the Extension Manager to install CommandSim Fire. To download the
Extension Manager, please visit http://www.Adobe.com/cfusion/exchange/index.cfm and then
click on words Extension Manager in the rightmost column of that page, about half way down the
page. The screen it takes you to will have instructions for downloading and installing the Adobe
Extension Manager. Once you have installed it, you can proceed to install CommandSim Fire.

Installing Extensions

IMPORTANT: Adobe Flash 8 or higher (CS3, CS4, or CS5) and Adobe Extension Manager version
1.6 or higher must be installed prior to installing CommandSim Fire.

1. Click on the download link for CommandSim Fire, or open the distribution CD (if you
received it by CD).

2. If you are downloading the file, save it to a location on your hard drive. When it has
completed downloading, either click on the Open button (from the download window), or
find csFI_v1.mxp in the hard drive location you specified and double-click on it to open it. If
you are loading CommandSim Fire from the distribution CD, go to the folder on the CD with
CSFI_vl.mxp and open it (double-click on it). The Adobe Extension Manager will open and
prompt you to Accept or Decline the license agreement.
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Macromedia Extension Manager

You are about 10 mitall the 'TS Fre Instructor’ edension. Flease 1ead the lolowing
caefuly before you cortnue

EXTENSION DISCLAIMER ~

PLEASE READ THIS DISCLAIMER CAREFULLY BEFORE INSTALLING ANY
EXTENSION. IF YOU DO NOT AGREE WITH THIS DISCLAIMER, THEN DO
NOT USE AND/OR COMPLETE INSTALLATION OF THE EXTENSION.

‘You are about 1o instal an Extension ovded by snd/or suthored by
Macromedia or a thad party. 'You understand and agres that Maciomedia may
NOT have authored the Extension you &e aboul to install. A thed party to which
Macromedia has no relalionship may have authored the Extennion of Maciomedis
1 |may have authoeed 2. You agiee that pou wil not distibute the Extension withoul
the wiitten consent of Macromedia and/or its icensos. You understand that the
third party author of an Extension may 1equire you Lo agree to certain tems and
condlions between you and the third paity author in ceder lor you 1o use such
suthot’s Extension

In the avent a third party fcenge agieement apeeals under the tils THIRD
PARTY LICENSE [IF ANY)' below, or accompanies the Extangion in a file, such
thrd party license agreement shall govesn the uze of the Extension in beu of any
download license agreement pou may have accepled when downioading the
Extension from Macromedia’s ste. provided, however, the provisions of this
Disclame: shall iemain sffective

Accepl ]I Declne l

3. Read the agreement to understand the terms, and click Accept to accept the Adobe
Extension Manager and CommandSim Fire Agreements. When you press Accept, the
Extension Manager will tell you that it is in the process of installing the extension.

Macromedia Extension Manager @

! : The 'CS Fire Instructor' extension has successfully been installed,

4. Click OK to acknowledge that CommandSim Fire has been successfully installed. Confirm
that Adobe Extension Manager shows CommandSim Fire Instructor installed and the
On/Off check box is checked on.
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File Help
& : i | : lFIash Basic 8 L] | (] | ®
| Unf‘Uff] Installed Extensions ] Yersion ] Type ] Author A
| [ & 360PanViewer 1.1.3 Flash Component [FL&) Flashloaded
'] & B-Line Charting Components@0 3.0.15 Other B-Line Express, Inc.
Clippets 1.2.1 Flash Dynamic Panel  Daniele Ugoletti
v & CommandSim Haz cards  1.0.0 Flash Companent [FL&) Jonathan Kaye e
v & C5 Fire Dept. Editi ponents 2.0.0 Flash Component [FL&) Jonathan Kaye
I v @& CS Fire Instructor 1.0.0 Flash Component [FL4) CommandSim
v @& CS Panorama Components 1.0.0 Flash Component [FL&) Jonathan Kaye
| & Dragénd Drop Tree 1.4.1 Flash Compaonent [S%WC) Alessandro Crugnola -
ob Extend Flash MX 2004 1.0.0 Suite Some Cool Guys
‘ 3] File Actions 01.0 Flash Dynamic Panel  Teknision Inc
[ & FileSystem - JSAPI Extension 1.00 Other Guy Watson
| | & FIS Nevies Interfare Camnanents 1 N0 Flash Camnanent (F1 &1 lanathan Kaun’ 5 !
| <

| Panorama (scrolling view] and navigation components, along with help files and tutarials, for CommandSim Fire
| Instructor Edition scenario development.

I The components are installed in the Components > CommandSim folder of the Components panel,

5. Exit (quit) Adobe Extension Manager.
6. Run (launch) Adobe Flash.

7. When Flash opens, you know CommandSim Fire was installed properly if you see a
CommandSim folder underneath the "Create from Template" title:

Create from Template

) Advertising
n 7 CommandSim
1 |7 Form Applications
) Global Phones
cation File (o | Japanese Phones

By default, the Adobe Extension Manager installs the CommandSim Fire components, help files, and
templates.
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Chapter 2
Introduction to the Elements of Flash

If this is your first time ever opening Flash, the user interface can appear a bit overwhelming. The
videos included with the distribution (on your CD or inside Flash) can help you gain comfort in
navigating and using the different elements of the interface.

Accessing Help in Flash

One of the most basic yet important skills to develop is to access Flash Help. If you do not know
how to access Flash Help, watch the video included with the distribution.

Overview of Flash Elements

Virtually all of your interactions will be using the following windows or areas in the Flash user
interface:

2 Mt dia FLyih edessnend § - BNditind- 1 4] SLIE]

‘ ©  Cormedini
\ COMPONENTS PANEL =57 .
© @ Py st Samonid

TIMELINE 0 B v s ) )|
I A R T T e T | ¥ Uesmosest Soperter W .'J'-
e #” =

owmnt | Beinge | 2w |

TOOLBAR —M

STAGE e _ o

)

COMPONENT INSPECTOR PANEL
————

=— " s

g oo e |

& —=F == |*F _———= PROPERTIES PANEL

R e v i B .
R o e r o { _H

e The Stage: The (default) white area that defines the space your graphics will appear in. Any
graphic that goes beyond the Stage will get cut off at the boundary of the Stage. You can use
the Modify > Document... menu to change the Stage size.

e Timeline: Flash movies are analogous to regular movies which run at a defined frame rate
(frames per second). The timeline is where you put you graphics or animations based on when
you want them to appear. Each box is called a keyframe, and you add keyframes to produce
animations. For example, if your frame rate is 24 frames per second and you place a graphic on
the 25th frame, when the movie runs your graphic will appear after 1 second. You can change
the frame rate in the Modify > Document... menu.

The Timeline is set up to allow you to define what are called "layers." As its name suggests, a
layer is a surface onto which you put graphics on the Stage. If you put a graphic on one layer
that overlaps with a graphic on a lower layer, you will see the graphic on the top layer
completely, but only the part of the lower graphic that is not obscured by the top layer's
graphic.

e The Toolbar: The main tools you use to add text, draw graphics, make selections, etc.
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e The Properties panel: Whenever you select some element on the Stage and then view the
Properties panel, the Properties panel gives you the characteristics you can change about that
element, for example, name, width and height, x and y position, etc. Open the Properties panel
by selecting the menu Window > Properties.

e The Components panel: This window lists all the components (Flash extensions) you have
installed currently. When you want to use an extension, you drag-and-drop it onto the Stage.
Open the Components panel by selecting the menu Window > Components panel (in Pro
versions of Flash, you would choose Window > Development Panels > Components).

e The Component Inspector panel: This window is for changing parameter values. You reach
this by either selecting the Component Inspector panel from the Window menu, or by clicking
on the "Launch Component Inspector" button on the Properties panel when you have selected a
Flash component. Open the Component Inspector panel by selecting the menu Window >
Component Inspector panel (in Pro versions of Flash, you would choose Window > Development
Panels > Component Inspector).

e The Help window: You access the Help window by clicking on the Help > Flash Help menu.

If you have Flash MX 2004, when you open Help, you will see two tabs in the top left corner of
the window. Click on the Help tab, and then the book icon in the icon bar below the tab.

If you have Flash 8, you will see the books arranged as in the picture below on the right.

In the Help books, you will find the CommandSim Fire Instructor Help document. Open the Help
panel by selecting the menu Help > Flash Help. The illustration below points to the Help document.

ey e
' ¥ Help [+ HazMat Placards

| CommandSim Fire Instructor

Hel l
SR ot I =| CommandSim Fire Instructor
P m p @ | Update@ E| Installing Commandsim Fire In...

C3) Introduction to the Elements of...

=| CommandSim Effects Generator

Fire Clips

Picture Scroller

| 360 (degree) Panorama Scroller

Picture Mavigation

I leima Elach Mavdiac in Micvacaf

Accessing the Help Books in Flash Help Panel Books
MX 2004. To get to the Help books,
click on the book icon when you
open Flash Help (Flash MX 2004

only).
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How to Produce and Use the Resulting Movie

The end product of Flash animations are called
"Flash movies". When you create a movie in the
Flash authoring environment and save this file, it
is called the "source file", and has an extension
(that is, on Windows, the last few characters
after the dot in the name) named "FLA". For
example, you will see several samples included
with the distribution of type "FLA": sample.fla, in-a, swf
myEffects.fla, etc. You can open these files only
if you have the Flash authoring environment
(Flash 8, Flash MX 2004, etc.).

Whenever you want to create the end result Images of a Flash source file and a Flash
movie, you go through a process called "testing executable file

the movie", or "publishing the movie." This
converts the source file into a file that you can
distribute to others (and "Executable File", in the picture on the right). You "test the movie" by
choosing the menu Control > Test Movie. Make sure to save your FLA first in place you know about,
and then Flash will create the resulting movie in the same folder. The resulting file has an extension
of "SWF", for example, sample.swf (produced by a sample.fla), myEffects.swf (produced by
myEffects.fla), and so on.

You do not need to have the Flash authoring environment to view SWF files: you just need the free
Flash browser plug-in (which is provided by default on most computers in the past few years).
Typically, you will distribute both an HTML (web page) file with your SWF. In the Flash authoring
environment, you can create the HTML page along with the SWF file by choosing the menu File >
Publish. Flash will create an HTML page with the same name as your FLA file, along with an SWF
file, but of course with an HTML extension instead of FLA or SWF.

Note: Flash can also produce other files such as PNG's, JPG's, etc. Look into File > Publish
Settings... to see what Flash produces when you issue File > Publish.

If you just receive an SWF file, without an FLA or HTML, you can view the result by dragging and
dropping it into a browser. If the Flash authoring environment is installed on your machine, you can
even just double-click on the SWF file and it will play in its own window. If you just have an SWF
file, you can view it but not modify it. To modify the movie, you must have access to the FLA file.

To embed your movie in PowerPoint, you will use the SWF file, not the FLA or HTML.

Using Flash Templates
When you start Flash, you are given the option to create a new Flash document, open an existing
document, or choose to create a new document from a template. You can see under the "Create

from Template" area that we have a CommandSim folder in which we have made several Flash
document templates for you to simplify some tasks in getting start.

If you open this folder, you will be presented with a list of the available templates:
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New from Template

Genersl | Templates
Category: Templates: Preview:
| Advertsing | @) Basic 360 Scroll

" Basic Image

Form Applcations &) Basic Scrolled Image
Ghbal Phones

Japanase Phones | a Instructor Foorplan
PDAS ﬁ Masked Image
Photo Skdeshows

Presentations
Quiz
Shde Presentations

Description:

A template with one image layer
provided by default,

| ok || cance

Once you create a Flash document from a template, you edit it and save it exactly as if you had
created a new Flash document--you will not be overriding the template file.

Note: To ensure compatibility with Flash MX 2004 (Flash 7), we created the templates using Flash
MX 2004. Therefore, if you are using Flash 8 or later, when you save your file, Flash will ask you if
you want to convert it to Flash 8 format. Saving it in Flash 8 format will not affect playback--viewers
will only need the Flash 7 player to see your scenes.

Here are some of the templates we provide and what customizations we have made in them:

Template Description
Name

Basic Image A Flash document of size 640x480 pixels with a frame rate of 15 frames
per second. It has one timeline layer named "photo" for putting your
photos on.

A Basic Image document with two additional timeline layers:

Masked one for placing smoke and fire, and the second (top layer) for placing a
Image mask. A mask lets you give dimensionality to your visual by letting
smoke and fire appear like it is coming from behind structures or
through windows, etc.

Basic This is for photos in which you want viewers to be able to look around
Scrolled (scroll) beyond what will fit on a single screen. The template contains
Image the CommandSim picture scroller already, and instructions for bringing

in your photo.

Note: We recommend you gain comfort with basic images before you
try to create scrolling images.

Basic 360 This is like the Basic Scrolled Image template except that it assumes the
Scroll image you bring in is a 360 degree picture of the scene. The template
contains the CommandSim 360 panorama scroller already, and
instructions for importing your picture.

Note: Like the Basic Scrolled Image template, we recommend you get
comfortable with basic images before you try to create 360 panoramas.
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Chapter 3
CommandSim Effects (CS Effects)

CommandSim Effects ("CS Effects") is a flexible tool (Flash extension) to create realistic smoke, fire,
and other special effects. Modeling smoke properly is one of the most critical aspects of making
your training effective, since teaching firefighters to "read smoke" (a term popularized by David
Dodson, of Response Solutions LLC) and predict hostile events can help them avoid disastrous
decisions being made on the fireground. With proper knowledge of smoke behavior, you can use
CommandSim Effects to teach firefighters those critical cues.

CS Effects produces smoke and fire that look like video clips, but in reality they are much more
flexible. You can choose one of the default smoke, fire, and HazMat patterns we have included, or
modify any or all of their more than forty (40) parameters, such as wind, turbulence, volume,
density, etc. to achieve precise behavior you need.

Other fire and smoke simulation systems provide different types of smoke and fire but do not have
the ability to gradually transition from one condition to the next, for example, smoke conditions
getting heavier and darker. Because of the way CS Effects works under-the-hood, you can make
your smoke effect transition naturally and easily, to create the highest level of realism possible. This
is achieved using CS Effects to determine the smoke or fire pattern, and CS Transition to handle
how one effect blends into the next. Check out the CS Transition documentation to see how easily
you can make your conditions change smoothly and naturally.

Using CS Effects

Using CS Effects is simple. You place one token in each place over a photograph you want smoke,
fire, or an effect to appear. The user interface makes it easy to choose from patterns we have
provided or you have created, and customize those patterns to fit your exact needs for the scenario.
You can even extend CS Effects with your own smoke, fire, water, foam, etc. graphics and control
its behavior using the standard interface, and share effects with other CommandSim customers.

Because CS Effects dynamically generates its effect based on the current set of parameter values,
you can change those values over time to product realistic condition changes. The CS Transition
extension lets you set the start and ending effect conditions, and smoothly changes from the
starting effect to the ending effect over time. You can tell CS Transition when to start the transition-
-a mouse click, a key press, or at a specific moment in time.

How CS Effects Works

CS Effects simulates smoke, fire, and effects by moving individual graphics ('puffs', or 'particles') in
a mathematical sequence according to speed, rotation, angle, etc. In technical terms, this is known
as a "particle generator", since the system creates particle puffs and moves them along a path that
simulates the way smoke or fire behaves. You can modify both the graphics and the parameters
that determine the path. We provide a default set of puff graphics, but you can supply your own to
create a limitless set of effects, such as water flow, specific kinds of smoke, fire patterns, smoke-
filled rooms, etc.

This approach is contrasted with systems that create smoke by playing video clips. The advantage
of the CS Effects way is that you can control how the effect behaves to a much greater degree of
freedom than approaches that use video clips. The disadvantage is that creating a lot of smoke and
fire in the same visual can slow down the simulation, depending on your computer processor speed.
When this happens, often you can replace groups of similar smoke patterns with a single smoke
pattern that combines graphics.

Organization of Help

The following sections present how to use CS Effects, from the Quick Start Guide through
programming smooth condition changes. The main sections are:

1. Quick Start Guide. Tells you how to create your first visual within 10 minutes.
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2. Understanding the CS Effects User Interface. Introduces you to the overall process of using
CS Effects in your scene, and walks you through all the screens of the user interface,
including the three main sections: the Library (USE), Editing Effects (EDIT), and Sharing
Effects (SHARE).

= USE: Using the CS Effects Library. The Effects Library is a collection of smoke, fire,
and HazMat patterns provided by default. You apply an effect pattern by clicking on the
name of the effect. Using the EDIT functionality, you can edit any pattern to come up with
your own patterns, and add them to your Library, and even share your unique creations
with others (SHARE functionality).

= EDIT: Adjusting CS Effects Parameters. Starting with a basic pattern, you can edit
any of 40 or more parameters, such as velocity, volume, density, color, wind, and gravity,
among others. Once you achieve the exact effect you want, you can save it to your Library
for instant retrieval in other circumstances.

. SHARE: Extending your Library through Sharing CS Effects with Other Customers.
CS Effects lets you easily share effects you have created with other customers.

3. Constraining Effects to Appear from Behind Buildings or Objects, or through Windows. This
tutorial goes step-by-step to show you how to simulate dimensionality in your scene. You
place smoke and fire at their appropriate location and then tell Flash which parts to obscure,
making it seem like the effect is in front of, or behind, elements in your photograph.

4. Advanced Topics

. Creating New Graphics to Extend CS Effects. Under the hood, CS Effects is a
powerful "particle generator"” that lets you control the path of any type of graphic element.
By default, CS Effects includes particles that look like smoke and fire, but you can make
and add your own graphics to simulate water, fluids, or any other kind of plume or puddle.

= Programming CS Effects. You can take precise control of a CS Effects through
programming its behavior. This section introduces the basic concepts of programming an
effect. The CS Transition extension lets you change smoke and fire conditions without
programming.

. This section teaches you the basics of controlling CS Effects precisely through
scripting/programming, to achieve special effects. The CS Transition extension is an easy
way to achieve many

. CS Effects Parameter Reference. Documents the parameters and methods of CS
Effects. Also details the normal operating ranges of the parameter sliders in the CS Effects
user interface, and the parameters values for the default smoke, fire, and HazMat effects.

CommandSim Fire: Instructor Edition, v1.5 10


../CommandSim%20FI/CSFI%20v1.5/assets/Help/CommandSim/a270_overall.html
../CommandSim%20FI/CSFI%20v1.5/assets/Help/CommandSim/a280_use.html
../CommandSim%20FI/CSFI%20v1.5/assets/Help/CommandSim/a287_edit.html
../CommandSim%20FI/CSFI%20v1.5/assets/Help/CommandSim/a310_share.html
../CommandSim%20FI/CSFI%20v1.5/assets/Help/CommandSim/a325_masks.html
../CommandSim%20FI/CSFI%20v1.5/assets/Help/CommandSim/a328_customParticles.html
../CommandSim%20FI/CSFI%20v1.5/assets/Help/CommandSim/a330_programming.html
../CommandSim%20FI/CSFI%20v1.5/assets/Help/CommandSim/a340_transition.html
../CommandSim%20FI/CSFI%20v1.5/assets/Help/CommandSim/a338_ref.html

CS Effects Quick Start Guide

Using CS Effects is essentially accomplished by opening a new Flash movie, loading your picture
background, dropping CS Effects tokens where you want to generate smoke and fire, and then
customizing the smoke and fire with slider bars. This quick start guide will review these steps in
detail to get you going!

Step 1. Start a new Flash document. Once you open Flash, choose New... Flash document from the
initial screen.

Create New

@ Flash Document

@ Flash Slide Presentation
@ Flash Form Application
&) ActionScript File

L] N mdimmCavied Camind imissdisae Cil

Step 2. When the program opens to reveal the Stage, use the menu item File > Import to Stage...
and go find a JPG or picture to load into the background. The picture should be somewhat small, but
later you can resize your pictures to fit your Stage.

File Edt View Insart Modfy Text Commands Control Window Heb

New.., CerbelN
Open.., Ctrid O
Open from Ske, ., 1
Opan Recent »
Chse Ctrisw Oy, s . o 8 » =
Close &1 Ctri+ A+ |
Save CtreS
Save and Compact e
Save As... Cirteshift+5 @ |4 o) G (e o
Save a3 Temolate, .,
Save All
Export 3 Import to Lbrary...
h R Open External Lbrary...  Ctrl+Shit+0
e S - Impoet Video...
Fublish Shift+F12

Step 3. Open the Components panel by choosing Window > Components. You will see folders when
this panel opens, and you should click on the plus sign next to the word CommandSim. This folder
contains the CS Effects extension, which is our smoke and fire generator.
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Step 4. Click and drag the CS Effects token onto the Stage, into whatever position you want to use

as the base of the smoke.

@

Step 5. Save your movie by going to File > Save. It will prompt you for a file name and place to

save the movie. Save it anywhere you'd like!

Step 6. Product your movie by choosing Control > Test Movie. Your first movie with smoke!

Step 7. Now let's see how to change the smoke pattern. With the CS Effects token selected (a thin

blue line appears around it), open the Compo
Component Inspector.

i v Component Inspector
2 CoEffects

Parameters |Bindings I Schema l

USE EDIT SHARE

nent Inspector panel by choosing Window >

i

S EFFECTS
VERSION1.0

SELECT EFFECT FROM LIBRARY

"1 Fire

DELETE

HazMat

B
> P
» ] Laminar Smoke
>

1 Turbulent Smoke

CREATE HEW EFFECT

NAME  |Light Grey TurbiLam ci

FOLDER  Laminar Smoke

v

Step 8. You will see the user interface for CS Effects in the Component Inspector panel. If the panel
is too small, move your cursor to a corner of it and click-and-drag it to enlarge the panel. If the
panel is stuck on the side, click-and-drag on the dots next to the title, Component Inspector, and

drag it away from the other windows.

CommandSim Fire: Instructor Edition, v1.5
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In the Component Inspector panel, click on an arrow next to a folder and then click on one of the
entries. This sets the effect to that pattern.

» | Fire & '

» ] HazMat ‘

¥ > Laminar Smoke
™ Dak Grey Lam

- Dense Black L,

Heawy Brown L

] B

1 Liaht Grey Turl _

Step 9. If you changed the effect pattern, test the movie by clicking on Control > Test Movie.
Alternatively, you can press the TEST MOVIE button on the CS Effects user interface (left side).

Step 10. You can edit the pattern with the conventional VOLUME, VELOCITY, DENSITY, COLOR by
clicking on the EDIT tab, and then moving a slider. If you want to modify more parameters, click on
the ALL SETTINGS tab, and then into a sub-panel (such as WIND, PARTICLE, COLOR, etc.)

I £
= =
2 CSEffects R

Parameters lBindings I Schema l

USE EDIT SHARE CS EFFECTS

VERSION1.0

MAIN SETTINGS

OVERALL
SIZE

large as D large

£ VOLUMEVELOCITY DENSITY BRIGHT

t small slow sparse small

_|Show Numeric Yalue

At this point you should be comfortable enough to add some more tokens or just play around with
the settings. Make sure to save your file periodically. Good luck!
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Introduction to the CS Effects User Interface

The interface for creating smoke and fire effects is broken up into three parts:

1. USE - Choose an effect from the Effect Library to instantly apply to the effect in your
movie.

2. EDIT - Edit any of more than 40 parameters of the effect to achieve exactly the look you
want.

3. SHARE - Share the effects you make with other CommandSim customers.
These Help pages will describe each of the parts in detail.

When you drag and drop a CS Effects item from the Components panel to the Stage, you will see a
circle with red wavy lines inside it. That is the CS Effects token. You change its behavior first by
selecting it (a blue line surrounding the token indicates that is selected):

@

and then opening the Components Inspector Panel. The Components Inspector Panel will look like
the following:

B £
i w Component Inspector =
D CSEffects L

Paramneters 'Bindings | schema |

USE EDIT SHARE CS EFFECTS

VERSION 1.0

* SELECT EFFECT FROM LIBRARY

_ A m

e
» ] HazMat
>
>

] Laminar Smoke

| Turbulent Smoke

CREATE HEW EFFECT

NAME [Light Grey TurbiLam o

FOLDER Laminar Smoke

If the window opens too small or too large, you can put your cursor on one of the corners, click and
drag to make the window smaller or larger. The interface will size to fit the window size you specify.
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Preview Area

On the left of the interface is the preview window. This shows you a static snapshot of the effect.
You can see how the effect looks over time by pressing and holding the PREVIEW button, located
at the bottom. If you want to see how your overall movie looks at any time, you can press the TEST
MOVIE button. This is equivalent to testing the movie via Control > Test Movie menu item.

The red arrow in the preview area is a way to change the orientation of the plume. You click and
drag it in a circular motion to specify at which angle the plume should be released.
Main Interaction Area

On the right-hand side of the interface, you can select the effect you want or modify it. You move to
the various sections by clicking on the tabs on top: USE, EDIT, or SHARE. The next sections
describe each of these pages in detail.

Using Effect from Your Effects Library

By default, we provide a series of smoke, fire, and HazMat effects to get you going quickly. These
are retained in your Effects Library, displayed when you select a CS Effects token on the Stage and
open the Component Inspector panel (Window > Component Inspector). In the illustration below,
you see your Effects Library as a series of folders.

B £

i w Component Inspector =
) CsEffects 3

Parameters |Bindings l Schema l

USE EDIT SHARE e il b

« SELECT EFFECT FROM LIBRARY

_ Fire

7 Laminar Smoke

>
» 71 HazMat
>
>

| Turbulent Smoke

CREATE HEW EFFECT

NAME  [Light Grey TurbiLam o m

FOLDER Laminar Smoke

If you click on the sideways triangle next to a folder name, the folder will expand to show you the
possible effects in that folder. We have organized the effects into a basic structure, but you can
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rename effects and folders to suit your needs. The effects are listed in each folder in alphabetic
order. You apply an effect by clicking on the effect name, as illustrated here:

» (7] Fire - l

» 1 HazMat

¥ > Laminar Smoke l
" Datk Grey Lam
" Dense Black L,

~ Heawy Brown L

= Light Grey Tur

By clicking on an effect name, the system sets the effect to that effect. The preview panel shows
you a glimpse of what that effect looks like.

Note: when you change the effect in the preview panel, it changes the effect in your movie. You
cannot go back to the effect you were viewing previously unless you saved it in your Library. As you
will see in later sections, you can create your own effects and add them to your Effects Library. Your
Effects Library is only accessible on your current computer (the one with CS Fire Instructor Edition
installed). Your Effects Library is not accessible from other computers. However, you can use the
SHARE feature to transfer effects from one computer to another.

Adding, Renaming, and Deleting Effects

This section describes how to add new effects, rename them, and delete them.

Adding a new Effect

In the course of making simulations, you will modify the basic fire, smoke, and HazMat patterns to
suit your purposes. You may create entirely new types of effects. Whatever the case, you can save
your work in your Effects Library, for future use, by assigning your effect a name (in the lower area
on the USE panel), and selecting the folder in which it will reside:

« CREATE NEW EFFECT

In the example above, we are showing how to create a folder--choose the "< New Folder >" folder,
and then name the folder in addition to the name of the effect. If you named your effect "My editing
fire" and directed the system to put it into the Fire folder, you would receive the following message
once you pressed ADD:
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Sucosss! Adasd My editing fire
to folaer Fire.

This message tells you that your effect was added successfully. If you were to navigate to the Fire
folder on our computer, you would see the effect.

Tip: It never hurts to create more effects than you need, since you always can delete them later. If
you don't save an effect, it will be easy to click over to a new effect and lose any changes you have
made.

Renaming an Effect

If you want to change the name of an effect, select that effect in your Effects Library and press
RENAME. A box (displayed below) will appear allowing you to type in the nhew name.

Rename effect
Dark Grey Laminar
to

[Mv Dark Laminarl

OK

If the name you chose already exists in the current folder, you must choose another name. Once
any name conflict is avoided, the system renames your effect. You can rename any effect you have
created, or any effect that is part of the default effect set.

Note: When you press the effect to rename, the system will change the current effect pattern to
that pattern, so if you do not want to change the pattern on Stage, make sure to save that pattern
first so you can go back to it after you have renamed the other effect(s).

Deleting an Effect

To remove an effect from your Library, click on the effect name and press the DELETE key. The
system will prompt you to confirm the deletion. If you press YES, the system will remove the effect
from your Effects Library.

Note: When you press the effect to delete, the system will change the current effect pattern to that
pattern, so if you do not want to change the pattern on Stage, make sure to save that pattern first
SO you can go back to it after you have deleted the other effect(s).
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Editing Effects

CS Effects lets you edit any of more than 40 parameters to achieve the exact look you need from
your smoke, fire, and other plume/stream effects. When you have the CS Effects token selected,
and you select the EDIT tab in the Component Inspector window, you are presented with the Edit
pane:

I X
! i w Component Inspector =
2 CSEffects X

Parameters IBindings ] Schema '

USE EDIT SHARE B e

MAIN SETTINGS

OVERALL
SIZE

large fast hick D large

¢ VOLUMEVELOCITY DENSITY BRIGHT

' sparse srall

_ PREVIEW.

| Show Numeric Yalue

From here you can modify the MAIN SETTINGS (shown by default) for the effect, or ALL SETTINGS
(all 40+ parameters).

You see from the visual above that you can modify parameter values by changing the position of the
sliders that accompany the parameter name. The sliders are actually changing the numeric values
of the parameter. You will notice that some parameters have a green bar on either side of the
slider thumb, such as in the VELOCITY parameter, above. This green bar tells you the amount of
variance currently applied to that parameter. Variance means that the actual value of each particle
will be selected from within that range, not the exact value given by the position of the slider
thumb. Variance gives a randomness look that can make smoke and other effects look more
realistics. If a parameter has a variance, there will be a separate slider that allows you to change
that variance value.
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Parameters of the MAIN SETTINGS

The first screen shown in the Edit pane gives you a quick way to modify conventional parameters
associated with smoke:

VOLUME. Overall size of the particle (puff) used. For a description of particles, please see
the first page in the Effects section. In reality, smoke volume is not simply equivalent to the size
of each puff, but this analogy provides an easy way to think about this smoke characteristic.

VELOCITY. How quickly the effect moves.

DENSITY. How thick the effect is presented. In our simulation, we vary the density by
changing the effect's transparency (or opacity). In reality, density is more than just transparency
of the plume--it also involves how tightly-packed the plume is, something we would translate to
Particles Per Frame (see the PARTICLES tab parameters to adjust this). However, using opacity
to render density changes is a simple way to achieve the approximate effect.

BRIGHT. Overall brightness of the plume elements (particles). This lets you simulate
various shades of the initial pattern. In the ALL SETTINGS tab, you can precisely modify the Color
of the plume, for example, to model hazardous gases. In that area, you can also tell CS Effects to
lighten or darken the plume when it reaches a certain point. This is designed to simulate the
effect that smoke lightens as it gets further from the source. If you modify the BRIGHT setting on
the MAIN SETTINGS panel, the system will adjust the final brightness value to remain consistent.
If you modify the BRIGHT setting in the Color panel, you can independently control the starting
from ending (final) brightness values, as well as at which point to start changing the brightness
from start to final.

OVERALL SIZE. A convenient way to make the plume larger or smaller overall.

I X
! i w Component Inspector i
&) CSEffects P

Parameters IBindings | Schema I

USE EDIT SHARE U5 EVVESTES

N1.0

MAIN SETTINGS

OVERALL

¢ VOLUMEVELOCITY DENSITY BRIGHT SIZE

small slow . srmall

|Show Mumeric Value
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If what you want to modify is not on the MAIN SETTINGS panel, you click on the words ALL
SETTINGS to reveal panels you can use to modify any CS Effects parameter.

Out-of-Range Values and Numeric Entry

The range of values for each slider has been determined to fit most typical uses. However, you may
find circumstances in which you want to create an effect requiring you to go beyond the slider
range. If this is the case, you can set the numerical value directly by click on the box marked "Show
Numeric Value", and then entering the numeric value directly in the box next to, or below, the
associated parameter:

If you enter a numeric value outside the slider range, a message comes up to replace the slider
indicating that the value is outside the slider range:

START WIND WHEN

AL I} L '} '}
[ QUTSIDE RANGE - SET VALUE NUMERICALLY | [sd ]

CTADT AZIMIN VADIAMICSE

The system will return to the slider if you enter a value within the slider range. Slider value ranges
are given in the Parameter Reference Guide section.
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Wind Parameters

You can precisely control the wind direction and strength using the controls on this panel.

VERSION 1

USE EDIT SHARE tedoniadl e
" MAIN SI ‘ ALL SETTINGS

//IND|PARTICLE DISPERSICN FADE INJCUT SIZE/SCALE
LIFETIME VELCCITY CCLOR DENSITY PERFORMANCE

WIND DIRECTION

START WIND WHEN

START WIND VARIANCE
l I —

WIND TRANSITICN ACCELERATICN

The controls are:

WIND DIRECTION. This gives the direction (left or right) and the wind strength -- the
further to the edge (higher positive number, lower negative number), the stronger the wind is.
Once you tell the system to apply wind in either direction, a button appears above this slider
which you can click on to return to the no wind setting.

Numerically, the slider range is -5 (full left) to 5 (full right).

START WIND WHEN. How long a puff/particle stays on the screen depends on its
LIFETIME value (set in the LIFETIME tab). The START WIND WHEN parameter says at what point
in the lifetime to start applying the wind, if there is any wind set.

Numerically, the slider range is 0 (beginning of particle's life) to the LIFETIME of the particle (can
vary based on user's setting).

START WIND VARIANCE. To make the wind appear more naturally, you can add some
variance to when the system starts to apply the wind. Higher values mean more variance. As you
change the variance, you will see a green bar expand or contract over the START WIND slider,
indicating the variation possible.

Numerically, the slider range is 0 (no variance) to 10.

WIND TRANSITION ACCELERATION. For strong wind, it becomes noticeable when the
wind kicks in because the particles start to drift suddenly. The WIND TRANSITION
ACCELERATION lets you set a gradual increase in wind so the wind accelerates to its strength
over time rather than all at once.

Numerically, the slider range is 0.5 (slow) to 5 (quick).
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Lifetime Parameters

The LIFETIME determines how long a particle/puff stays on the screen. The count is determined by

how many times the particle is updated (moves). This panel lets you set how long a particle lasts.
Several parameters are based on a particle's lifetime, for example, fade-in/fade-out, start wind

when, change brightness, etc.

The controls are:

VERSION 1

ALL SETTINGS

USE EDIT SHARE

— —— =)

R B ]

BAIN CET
2l )

[L WIAIN SETTINGS
WIND PARTICLE DISPERSICN FADE IN/CUT SIZE/SCALE

I LIFETIME | VELOCITY COLCR DENSITY PERFCRMANCE

LIFETIME

LIFETIME VARIANCE

LIFETIME. How long the particle remains on the screen. Higher values mean longer screen

life.

Numerically, the slider range is 10 (short life) to the 100 (medium lifespan).

LIFETIME VARIANCE. The number of steps to vary a particle's lifetime.

Numerically, the slider range is 0 (no variance) to the 20.

CommandSim Fire: Instructor Edition, v1.5
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Particle Parameters

The parameters on this panel relate to the specific particle/puff used in the current pattern.

VERSION 1

USE EDIT SHARE OGN ErrEaTe

304

ALL SETTINGS

WIND [PARTICLE|DISPERSICN FADE IN/CUT SIZE/SCALE
LIFETIME VELCCITY COLCR DENSITY PERFORMANCE

PARTICLE TYPE  Firzcsll

RELEASE RATE

TURBULENCE

RS Sl
[ [

TURBULENCE VARIANCE

The controls are:

PARTICLE TYPE. There are 5 graphics included, by default. Using the drop-down list, you
choose which graphic to use as the base puff/particle.

= White Laminar. Laminar look.

= Fireball. Flame ball pattern.

= DarkGrey1. Turbulent pattern.

= DarkGrey2. Turbulent pattern variant.

= LightGrey. Mix of laminar/turbulent look.

= CUSTOM. You can use your own particle to create an endless possibility of effects,

for example, water and other fluids.

LINKAGE ID. If you chose to create your own particle, this box and label appear and you
enter the Linkage ID of the movie clip you have created. See Creating a Custom Particle for
information about how to do this.

RELEASE RATE. This determines how often a particle is released by the generator.
Releasing a particle often, creating a dense pattern of particles, will require more computational
processing because the particles will endure through their LIFETIME value. Releasing a particle
less often may cause gaps between particles. In adjusting this value, you should consider also
adjusting the particle volume/size so you avoid gaps in the particle stream.

Numerically, the slider range is 0.05 (sparse) to 0.25 (dense).

TURBULENCE. Turbulence indicates how quickly each particle rotates. Higher values mean
more rotation, and greater the appearence of turbulence. This parameter is directional--values
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above 0 tell the particle to rotate clockwise, and values below zero tell the particle to rotate
counter-clockwise. Once you set a non-zero turbulence, a button appears which you can click to
reset the turbulence to 0.

Numerically, the slider range is -5 (high turbulence, counter-clockwise) to 5 (high turbulence,
clockwise).

TURBULENCE VARIANCE. To give a more realistic look, you can set a variation for the
turbulence. If the variation crosses 0, then some particles will rotate in different directions.

Numerically, the slider range is 0 (no variance) to the 5.

Velocity Parameters

Controls on this panel determine parameters related to particle speed.

VERSION1

USE EDIT SHARE o8 ErranTs

) AR

ALL SETTINGS

WIND FARTICLE DISPERSICN FADE IN/OUT SIZE/SCALE

LIFETIME |[VELCCITY| CCLCR DENSITY FERFORMANCE
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— 3 Y
INITIAL ACCEL. VEL. VARIANCE
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FRICTICN
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GRAVITY
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_
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The controls are:

CommandSim Fire: Instructor Edition, v1.5

VELOCITY. How quickly each particle moves. The value is in terms of pixels per update
(the number of updates is called the particle's LIFETIME).

Numerically, the slider range is 0.25 (slow) to .25 (fast).

INITIAL ACCELERATION. Number of updates to reach the set velocity. Since a particle
fades-in over a certain period, you may want the smoke the develop at the start location a bit
before it starts its travel. This gives a full-look to the smoke/fire source. A lower value means
quicker to reach the set velocity, a higher value means slower to reach the set velocity.
Numerically, the slider range is 0 (reaches set velocity immediately) to the 10.

VELOCITY VARIANCE. How much to vary the velocity.

Numerically, the slider range is 0 (no variance) to the 5.

FRICTION. Allows you to dampen the velocity by the set percentage. Friction is applied to
a particle's velocity each update.
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Numerically, the slider range is 0 (no friction) to the 30 (%).

FRICTION START. When to start applying friction, in terms of the particle's lifetime, if at
all.

Numerically, the slider range is -1 (no friction) to 10.

GRAVITY. Amount of gravity to apply. Any gravity set is in the vertical axis, irrespective of
the particle stream's release angle (set in DISPERSION panel).

Numerically, the slider range is 0 (no gravity) to the 0.25.

Dispersion Parameters

Dispersion parameters control how a particle is dispersed in the particle stream (plume).
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The controls are:

RELEASE ANGLE. The base angle at which the stream is released (0-360 degrees).
Directly vertical is 270.

Numerically, the slider range is 0 to 360.

SPREAD. Random angle (spread) of dispersion to release each particle, in addition to the
RELEASE ANGLE. For example, 20 means release particles randomly within +/- 10 degrees of the
release angle.

Numerically, the slider range is 0 (no spread) to 45 (+/- 22.5 degrees left and right).

RANDOM HORIZONTAL SHIFT. A random value used as starting x (horizontal) value for

the particle. Starting x value is chosen between negative half this value and positive half this

value. This is used to simulate variety in the origin of the plume.

Numerically, the slider range is 0 (no variation) to 100 (+/- 50 pixels to the left and right).
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SCALING. This determines how much to scale each particle once it reaches the SCALING
START point. Scaling is in addition to the original size/scale value (set in the SIZE/SCALE tab).

Numerically, the slider range is 0 (no scaling) to 5 (% per update).

SCALING VARIANCE. Use this parameter to add randomness to the amount of scaling, for

a more varied look.

Numerically, the slider range is 0 (no scaling) to 5 (% per update).

SCALING START. This is the point in the particle's life when scaling begins to be applied.
Small values (left on the slider) mean to start scaling early on. Higher values (right on the slider)
mean to delay scaling until later in the particle's life.

Numerically, the slider range is 0 (start scaling immediately) to the lifetime (number of updates)

of the particle.

SCALING START VARIANCE. This parameter lets you vary when scaling starts to apply,
for further randomness in plume appearance.

Numerically, the slider range is 0 (no variation) to 20 (updates).

Color Parameters

In the COLOR panel of ALL SETTINGS, you can finely tune the color and brightness of particles. In
addition to controlling the amount of red, green, and blue tint, you can set up the particles so that
they lighten or darken after a certain point in their lifetime. This can be used to simulate the
condition in which smoke lightens as it gets further from the source.

In the MAIN SETTINGS panel, you can only change the brightness.

USE EDIT SHAR

GREEN  BLUE
B

RED

A

E

WIND PARTICLE DISFERSION FADE IN/OUT SIZE/SCALE
LIFETIME VELCCITY |[CCLOR| DENSITY PERFORMANCE

CS EFFECTS
VERSION 1

ALL SETTINGS

END  VVHEN
BRIGHT gricht chance
-

The controls on this panel are:

RED. How much redness to apply. Numerically, the slider range is 0 to 255.

GREEN. How much greenness to apply. Numerically, the slider range is 0 to 255.

CommandSim Fire: Instructor Edition, v1.5
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BLUE. How much blueness to apply. Numerically, the slider range is 0 to 255.

BRIGHT. How much brightness to apply, from the starting point to the WHEN CHANGE
moment of a particle's life. If the END BRIGHT is the same as the BRIGHT, then no change
occurs. Numerically, the slider range is 0 to 120.

END BRIGHT. This sets the brightness to achieve at the end of the particle's lifetime. The
system calculates the difference between BRIGHT and END BRIGHT, then applies the change
over the course of WHEN CHANGE to the end of particle's life. This has the effect of lightening or
darkening the particle, if END BRIGHT is not the same as BRIGHT. Numerically, the slider range
is 0 to 120.

WHEN CHANGE. If the BRIGHT setting is different from the END BRIGHT setting, the
system changes the particle brightness beginning at the WHEN CHANGE point in the particle's
life, and finishing at the particle's lifetime end. This accomplishes a brightness change. The
system calculates the appropriate increment based on how much time is between the BRIGHT
and END BRIGHT settings. If BRIGHT and END BRIGHT are the same value, no change occurs.
Numerically, the slider range is 0 (particle's end of life) to the particle's lifetime (beginning of
life).

Fade-In/Fade-Out Parameters

To make a more natural and gradual start and end for a plume, you can control the fade-in and
fade-out of a particle over its lifetime.
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The controls are:

FADE-IN. In terms of the lifetime of a particle, this value sets when the particle is at full
opacity (set in the DENSITY tab). The system calculates the amount of fade-in required to
achieve this. If you set this value to 0, there is no fade-in. If you set it to the maximum value,
the particle fades-in over the whole life of the particle.

Numerically, the slider range is 0 (start of life) to end of lifetime.
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FADE-IN VARIANCE. You can vary when the fade-in completes by setting this parameter.

Numerically, the slider range is 0 to 20.

FADE-IN START OPACITY. This lets you set the opacity when the particle first appears.

By default, this is completely transparent (0), but you may have a situation in which you want
the particle to start at some non-zero transparency level.

Numerically, the slider range is 0 (transparent) to 100 (opaque).

FADE-OUT. After the fade-in has completed, the particle stays at the set opacity (density)
setting until it reaches the FADE-OUT point, which is given by this parameter. When a particle's
life reaches the fade-out point, it starts fading out from its current opacity to the FADE-OUT END

OPACITY, which is usually 0 (fully transparent).

Numerically, the slider range is 0 (start fade at end of particle life) to the particle's lifetime.

FADE-OUT END OPACITY. This determines the final opacity (transparency) value at the

end of the fade-out. Usually, you will want to end with the particle being fully transparent (0),
but you can decide to have the end opacity be any desired level.

Numerically, the slider range is 0 (transparent) to 100 (opaque).

FADE-OUT VARIANCE. You can vary when the fade-out begins by setting this parameter.

Numerically, the slider range is 0 to 20.

o Density (Opacity) Parameter

There is only one parameter in this set currently. The DENSITY parameter controls the opacity once

a particle has faded-in all the way (see the FADE-IN/FADE-OUT tab for more information about
this).

In reality, density is more than simply transparency. It also would involve how tightly-packed the

elements are in the plume, which one can control using the PARTICLES PER FRAME parameter. For
simplicity, however, opacity gives an approximation to density that is easier to explain and control.

Numerically, the slider range is 0 (transparent) to 100 (opaque).
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Size/Scale Parameters

These parameters tell the system about the overall size of the plume and the individual particle
sizes.

VERSON1

USE EDIT SHARE o

 MA 8 ALL SETTINGS
WIND PARTICLE DISPERSICN FADE IN/OUT|SIZE/SCAL

LIFETIME VELCCITY COLOR DENSITY PERFORMANCE

CVERALL SIZE
-  ——=
BASE PARTICLE SCALE (VOLUME)

BASE PARTCLE VWIDTH

BASE PARTICLE HEXGHT

The controls are:

OVERALL SIZE. This sets the overall size of the plume, in terms of percentage.

Numerically, the slider range is 50 to 200.

BASE PARTICLE SCALE (VOLUME). This sets the initial size of each particle, in terms of

percentage of the original particle/puff graphic. If you use this slider, it sets the WIDTH and
HEIGHT to be the same. If you modify the WIDTH or HEIGHT separately, so they are not
equivalent, this BASE PARTICLE SCALE is ignored.

Numerically, the slider range is 30 to 150.

BASE PARTICLE WIDTH. This control lets you scale the width of the base particle

independent of the height, to get a squeezed-down/up look. If you modify this value, the system
uses this value as the particle width. If you modify the BASE PARTICLE SCALE, it sets the WIDTH

to that value.
Numerically, the slider range is 30 to 150.

BASE PARTICLE HEIGHT. This control lets you scale the height of the base particle
independent of the width, to get a squeezed-in/out look. If you modify this value, the system
uses this value as the particle height. If you modify the BASE PARTICLE SCALE, it sets the
HEIGHT to that value.

Numerically, the slider range is 30 to 150.

Performance Parameters

The PERFORMANCE tab contains controls that relate to the generator's performance characteristics.
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The controls are:

PRE-COMPUTE PLUME. This setting controls how many updates to compute BEFORE the
plume is shown. If your purpose is to see a fully-developed plume when the visual is first shown,
you should set this value to a humber higher than the LIFETIME value. If you want to show the
plume developing, you should set this to NONE or a low value.

Numerically, the slider range is 0 to 200.

REDRAW EVERY FRAME / REDRAW AT INTERVAL. The more CS Effects you have
operating at the same time, the more difficulty your processor will have in keeping them all
running at top speed. If you have many CS Effects going at the same time, to the point at which
it is interfering with interaction, you can set the visual update interval (the slider) to update the
graphics less frequently than every (Flash) frame. The number is the frequency, in milliseconds,
to update the graphics, so a value of 100 means 10 times per second.

Numerically, the slider range is 20 to 150.

FASTEST COMPUTATION. The CS Effects particle generator requires a fair amount of
computation to perform. By default, we set the quality of the Flash movie to LOW, which means
to approximate the drawing of lines, but retain pictures (JPG/PNG/etc.) at a satisfactory viewing
level. If you leave FASTEST COMPUTATION checked, the system will set the quality to LOW. If
the setting is unchecked, the system will set the viewing quality to HIGH. At HIGH quality, you
may see some artifacts in terms of the overlap of particles, so we recommend leaving this box
checked.

NEW PARTICLES IN FRONT. When CS Effects adds a new particle to the plume, it can
either add it in front of all the others, or behind the others. By default, we have particles
generated in front, simulating a smoke source that is in front of the plume. If this check box is
unchecked, the new particles will appear behind the older particles, giving the appearance of the
smoke source being behind the plume. A situation in which you want the checkbox unchecked is
if you want to simulate particles coming towards you, so the new particles are being generated
behind the plume.

STREAM ACTIVE: Whether or not the plume is moving.
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Sharing Effects

The power of CS Effects multiplies when you consider that you can publish your customized effect
for others to use, as well as download custom effects others have created (and then customize
those!). Coupled with the feature that lets you create your own custom particle graphics, the

possibilities are virtually limitless.

Sharing effects occurs in the SHARE tab of the user interface, as illustrated below.
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VERSION 1.0
share your effects on our web sife

or grab some new ones!
(CLICK HERE to go to this sife now)

SHARE YOUR EFFECT
Name your effect, then press COPY TO CLIPEOARD, and
paste the code into an email or note, or post it online!

NAME YOUR EFFECT |

COPY TO CLIPEOARD

LOAD NEW EFFECT
Paste effect code in the box below by copying the effect
code, right-click on the box below, then choose Paste.
Press LOAD EFFECT to load it. If youwantto add itto
vour library, click on the USE tab above and add it as a ne

EFFECT CODE |

LOAD EFFECT

The two operations in this panel are:

1. SHARE YOUR EFFECT. Takes the current pattern and copies out the parameters for you to
share with others. The string of parameters is called the effect code, which you don't see
though it does get copied into your Clipboard for pasting into an email or onto our discussion

board posting.

2. LOAD NEW EFFECT. When you get a new effect, from others or from the web site, you
paste in the effect code and then instantly the effect appears in your movie (if you want to
keep it in your Library, you have to add it there, though).

The effect code is simply a string of characters representing the parameter values for your custom

effect, for example:

Light Grey

Turb/Lam, 96,10,4,0.175,5.292,1, true, 50,50,50,101,100,90,27.64,120,120,120,0,0.87,0,3

0,

0,5,100,10,0,0,39,5,0,40,%90.8,2.9,23,0,0.0164,0,0,105, true, 0,270, true, LOW, true, 25,
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You can pass around this string to others who have CS Fire Instructor and they can use your effect
immediately. On our web site, we have devoted a section of the discussion board to share effects.
You can download control strings we or others have created, and we encourage you to publish your
own.

Publishing Your Custom Effect

1.  To publish your custom effect, navigate to the SHARE tab on the CS Effects user interface.

2. Under "SHARE YOUR EFFECT", type a name for your effect in the box on the right.
Note: the name you enter is placed on the Stage next to the clip, to make it easier to sort
out the different effects you have placed.

3. When you are done, press the button marked COPY TO CLIPBOARD. The effect control
string is now in your clipboard for you to share.

4. Go to our web site discussion board and start a new topic, then paste the string into the
message area. Describe the effect for others so they know what they would be downloading.

Note: if your effect requires a custom particle graphic, you must also supply the skin (graphic)
when you share your effect. The easiest way to do this is to create a new Flash file (FLA) that only
contains your custom graphic movie clip.

Loading a Custom Effect

1. Copy an effect code into the clipboard. The string can be from our web site, or from email
or any other text source.

2. In the area marked LOAD NEW EFFECT, right-click on the box next to the button marked
"EFFECT CODE" and select Paste. This pastes the contents of the clipboard into the box. You
can manually enter the values, but this is a tedious and error-prone process.

3. Press the LOAD EFFECT button. If the control string is well-formed, you will see the result in
the preview window on the left. If not, the system will tell you "too few parameters!" and
you'll need to re-enter it. If this problem persists, check to see that you copied the whole
effect code.

4.  You can now modify the effect using the sliders or numeric entry in the EDIT tab.
Remember that until you save the effect in your Library, if you go to the Library tab and click
on an effect from your Library, it will overwrite the current settings (so don't do this unless
you intend to!).

5. The effect is not automatically placed in your Library--follow the steps in the next section to
add the effect to your Library.

Saving a Custom Effect in Your Effects Library

Once you have loaded an effect into the interface, it is set for the selected token, but it is not saved
in your Library. To save it in your Library, click on the USE tab. In the area marked Custom, enter a
name for your effect (the one that came with the effect is provided by default, but you can make it
whatever you'd like). Choose an effect folder, or create a new folder. Finally, press ADD and the
effect will now be saved in your Library.

Default Library Effects

If you delete one of the effects that were provided by default, the effect is gone just as if it were an
effect you created. You can use the following table to load a default effect into the library if you
have accidentally deleted one. Select the effect control string of the effect you want, copy it, and
paste it into the Load Effects area in the interface.
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Name

Effect Code

Fire Folder

Regular Fire Regqular Fire,33,0,1,0.2,4.69,1,false,0,0,0,100,100,18,23.38,115,115,115,
0.09,3.09,0,30,0,5,100,5,0,0,17,0,0,40,100,-3,10,0,-
0.3,0,0,80,true,0,270,true,LOW,true,26,0,Fire

Rolling Fire Rolling

Fire,33,0,1,0.25,8.012,1,false,0,0,0,100,100,18,43.31,150,150,150,0.09,3.09,0,
30,0,5,100,5,0,0,26,5,0,40,100,0,10,0,-
0.3,0,0,80,true,0,270,true,LOW,true,26,0,Fire

HazMat Folder

Ammonia Ammonia,95,5,0,0.2,3.85,0,false,0,0,0,100,100,6,15.9,67.26,67.26,67.26,0,0.9,
0,30,0,5,76,10,0,0,71,5,0,40,94.5,1.5,13,0,0.0245,0,0,105,true,0,270,true,LOW,
true,25,0,HazMat

Chlorine Chlorine,300,0,3,0.13,1.2,0,true,64,73,0,120,120,6,180,91.62,91.62,91.62,0,0.3

approach 3,0,30,0,5,76,10,0,0,54,5,0,40,100,1.5,13,0,0,0,0,100,true,0,87.92,true,LOW,fal

se,25,0,HazMat

Laminar Smoke Folder

Dark Grey
Laminar

Dark Grey
Laminar,75,8,0,0.1439,1.971,1,true,0,0,0,38,41,20,6.19,65,65,65,0,0.9,0,30,0,5
,100,10,0,0,44,5,0,40,100,1.6,20,3,0,0,0,80,true,0,270,true,LOW,true,10,0,Lami
nar Smoke

Dense Black
Laminar

Dense Black
Laminar,100,8,0,0.175,3.702,1,true,0,0,0,18,19,6,30.14,90,90,90,0,0.9,0,30,0,5
,100,10,0,0,44,5,0,40,80.9,1.3,20,3,0,0,0,80,true,0,270,true,LOW, true,10,0,Lam
inar Smoke

Heavy Brown
Laminar

Heavy Brown
Laminar,100,8,0,0.1439,1.971,1,true,19,18,0,16,41,15,30.14,84.13,84.13,84.13
,0,0.9,0,30,0,5,100,10,0,0,44,5,0,40,100,0.5,20,3,0,0,0,80,true,0,270,true, LOW
,true,10,0,Laminar Smoke
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Light Grey Light Grey

Turbulent/ Turb/Lam,96,10,4,0.175,5.292,1,true,50,50,50,101,100,90,27.64,120,120,120,0

Laminar ,0.87,0,30,0,5,100,10,0,0,39,5,0,40,90.8,2.9,23,0,0.0164,0,0,105,true,0,270,tru
e,LOW,true,25,0,Laminar Smoke

Steamy Steamy

Knockdown Knockdown,80,10,0,0.175,2.749,1,false,0,0,0,100,100,65,24.61,72.92,72.92,72.

92,1.5,0.5,0,30,0,5,100,10,0,0,56,5,0,40,100,1.7,13,3,0,0,0,80,true,0,270,true,
LOW,true,10,0,Laminar Smoke

Steamy Light
Grey

Steamy Light
Grey,70,14,0,0.175,1.971,1,true,0,0,0,78,78,55,24.61,72.92,60,60,1.5,0.5,0,30,
0,5,49,10,0,0,36,5,0,40,100,2.5,20,3,0,0,0,80,true,0,270,true, LOW, true,10,0,La
minar Smoke

Wood Burn
Light

Wood Burn
Light,50,8,0,0.1439,1.971,1,true,18,12,0,58,72,35,6.19,50,50,50,0,0.9,0,30,0,5,
100,10,0,0,37,5,0,40,100,2.5,20,3,0,0,0,80,true,0,270,true, LOW,true,10,0,Lami
nar Smoke

Turbulent Smoke Folder

Black Black

Turbulent Turbulent,96,10,2,0.175,5.292,1,true,0,0,0,49,78,6,27.64,120,120,120,0.76,1.2
3,0,30,0,5,100,10,0,0,39,5,0,40,90.8,2.9,23,0,0.0164,0,0,105,true,0,270,true,L
OW,true,25,0,Turbulent Smoke

Brown Brown

Turbulent Turbulent,71,14,3,0.2,3.914,2,true,36,24,0,44,72,6,20.93,97.3,97.3,97.3,0.76,1
.23,0,30,0,5,100,10,0,0,36,5,0,40,94.5,3.6,13,0,0.0164,0,0,105,true,0,270, true,
LOW, true,25,0,Turbulent Smoke

Dark Grey 1 Dark Grey 1

Turbulent Turbulent,95,14,2,0.2,4.513,2,true,40,40,40,44,72,6,20.93,97.3,97.3,97.3,0.76,
1.23,0,30,0,5,100,10,0,0,54,5,0,40,94.5,2.2,13,0,0.0164,0,0,105,true,0,270,tru
e,LOW,true, 25,0, Turbulent Smoke

Light Grey Light Grey

Turbulent Turbulent,100,8,2,0.2,5.502,1,true,30,30,30,160,113,6,30.14,100,100,100,0,0.9
,0,30,0,5,100,10,0,0,44,5,0,40,71.7,2.4,17,12,0.0399,0,0,100,true,0,270,true,L
OW,true,10,0,Turbulent Smoke

Medium Grey Medium Grey 1

1 Turbulent Turbulent,95,14,2,0.2,4.513,2,true,40,40,40,100,100,6,30.14,97.3,97.3,97.3,0.7
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6,1.23,0,30,0,5,100,10,0,0,54,5,0,40,94.5,2.9,13,0,0.0164,0,0,105,true,0,270,tr
ue,LOW,false, 25,0, Turbulent Smoke

Medium Grey Medium Grey 2

2 Turbulent Turbulent,95,14,2,0.2,4.513,2,true,40,40,40,100,100,6,20.93,97.3,97.3,97.3,0.7
6,1.23,0,30,0,5,100,10,0,0,54,5,0,40,94.5,2.2,13,0,0.0164,0,0,105,true,0,270,tr
ue,LOW,true,25,0,Turbulent Smoke

White White

Turbulen Turbulent,95,14,3,0.2,4.513,2,true,40,40,40,160,113,6,30.14,97.3,97.3,97.3,0,0
.9,0,30,0,5,100,10,0,0,45,5,0,40,94.5,2.1,13,0,0.0254,0,0,105,true,0,270,true,L
OW,true,25,0,Turbulent Smoke

Simulating depth by Adding Elements with Masked Drawing Regions

When you need to add dynamic elements such as animations to your scene, such as smoke, fire, traffic, people,
etc., you typically want to simulate its appearance moving behind elements of your photograph. In this example,
let's see how to make smoke appear from behind a bush (pictured on the right). You can use this procedure to
simulate depth effects for static and moving objects, for example, cars, people, or other vehicles.

The basic concept is to think of the layers in Flash like pieces of cellophane. If you place opaque or translucent
graphics on different layers, and view it from the top, you can see the graphics as a composite image based on the
graphics on each layer and which layer is above another layer. For this example, on the bottommost layer, you
place the base image, the smoke on the next layer above that, and then a special graphic, called a mask layer, to
hide areas of the layer on which you have smoke.

Step 1. The first step is to open up a new Flash document. The timeline will be shown at the top, which will look
like this:

2 QUL view Llisere oy TEXAL LUHINGNUS LUl winuuw - neip

Tools D@ s 28 9 = 8 »5

[T T T DU T U T PO PN O T T OO DO X X |

3
=

A

L aadll] = u 5
” _

=

* 7 Voan i || i) ) el =

Colors

Step 2. Next, we want to bring a photograph or image of the scene. Click on the File menu, and the Import >
Import to Stage... menu item, and find a GIF or JPG of your background.
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Macromedia Flash MX Professional 2004 - [Untitled-1]
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Step 3. When you have brought in the image, you will see a filled-in dot on the timeline in the keyframe marked 1.
For recordkeeping, rename the layer from Layer 1 to "image" (you can do this by clicking on the layer name, Layer
1, and typing the word "image" [no quotation marks]).

Untitled-1*

Step 4. We're going to put the smoke on a new layer above the image. It's a good idea to keep things in your
movie on different layers -- it makes it easy to isolate them if you need to make the invisible during editing, or
otherwise treat it differently from other elements in your movie.

Now create a new layer on top of your image layer. Do this by clicking on the small sideways page with a plus sign
(lower left corner of image above). This will create a new layer, by default, called Layer 2. Notice the empty dot
shows up, meaning there is nothing in this layer yet.
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Step 5. Let's overlay a CS Effects particle generator In our example, we opened the Components panel (Window
> Components), found the CS Effects generator component, and placed it on the tree. Make sure the element is
on Layer 2 by clicking on the empty dot, not the filled in dot on the image layer!

£ 4% @ || 4] Blo] Bl

You can rename your Layer 2 to something like "smoke", just so you remember what is on that layer.
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Step 6. If you were to test the movie now (which is fine, if you're working alongside us), you would see the smoke
in front of the tree. Now we need to make a mask region to block the smoke from appearing in front of the tree, but
let it show up behind and above the tree. Create a new layer, name it "mask"”, and use one or more of the drawing
tools on the main Toolbar (rectangle, paintbrush, point-to-point pen tool, etc.) to draw the region you want the
smoke to appear. Make sure you are drawing on the mask layer, not on one of the other layers. The color is not
important at all, only really the filled in area. For example,
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Strangely enough , this is called a "mask layer" even though you are drawing the part that should show through,
not the part that is masked, which would make more sense based on the word masked! (we don't know how Adobe
came up with that term!). Make certain that the stuff you draw is on the mask layer.

Important: If you are using Flash 8, after you have drawn your shape, click on Modify > Break
Apart. This changes your drawing to the crosshatch pattern you see in the figure above. Any
painting you do will be created as a Drawing Object which you need to Break Apart in a similar
manner.

Step 7. Now it simply looks like a blob on top of some portion of the image. To activate the mask, right-click on the
name of the layer (in our case, "mask"), and choose "Mask":
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You can tell that it worked properly if the little icons in from of the mask layer and the smoke layer change to a
green patterned circle and rectangle, as illustrated here:
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You'll also see little locks appear on the layers. Flash automatically "locks" the layers to prevent accidental
changes. You can unlock the layers by clicking the lock icon, and then you can modify the elements on that layer.
For example, you might want to change the mask region, or alter parameter values of your CS Effects instance. If
you do not unlock the layers, you cannot select the elements to change them.

When you complete this step, you will see the blob disappear, and you will see your element cropped to within the
boundaries of the visible part of your mask. Test your movie, and you will see the smoke rise from behind the tree!
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Tips for Added Realism: In this case, you see a sharp border between the smoke and the tree. Masking is only
possible with sharp borders, but you can make your mask fill very detailed so it does not have such a uniform
edge. Another trick is to create a layer on top of your mask layer and place graphics there with transparency (a
more advance design technique). Because the layer is on top of the mask, it will cover the graphics on layers
below it, giving the appearence of being in front of (closer to the viewer) the smoke.

Creating Custom Particle Graphics

CS Effects comes with a set of puff/particle graphics that are the basis for creating the various
effects, for example, smoke and fire types. For the intermediate to advanced user, CS Effects lets
you specify your own particle graphic and the system parameters can be applied to plumes or
streams using that graphic.

This section describes how to inject your own graphic as the basis for a plume or stream. For
example, you can make a special kind of smoke, or a water-from-a-hose pattern.

Important: You should be comfortable with the concept of Flash keyframes, and possibly movie
clips, to read this section.

Creating a Custom Graphic

Typically, custom particle graphics will be PNG files that you create with image processing programs
such as Adobe Photoshop. You can create a new graphic using any tool and save it as a PNG file.
PNG is the preferred format because it has many levels of transparency, so if you want to make a
particle graphic that is fuzzy and has smooth edges, you can gradually taper the transparency to
the edge of the graphic. Describing how to create a semi-transparent PNG is beyond the scope of
this document, but you should find help in those programs for making graphics with soft edges.

To give your particle stream some variety, we suggest you make a few different variations of your
graphic, rather than a singleton. For example, we have made the following graphics to illustrate this
process:

Creating a Movie Clip to Hold Your Graphics

Once you have made your graphics, you need to create a "movie clip" (a Flash concept) to hold
your graphics. Open a new Flash document, and then choose Insert > New Symbol... from the
menu. Enter a symbol name into the box, such as My Custom Particle, make sure the Type is set to
Movie clip:
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Create New Symbol

Name: | My Custom Particle

BE Type: (& Movie clip Cancel
" Button
(" Graphic

Advanced

i,

Click on the Advanced button, if it is displayed, and then your dialog box will look as follows:

i
Nera ! [ﬁy Custon Particde o I
Typet = Move do Cancel
T !
S [ o= ]

il
|
Urkage: T Export for Actondergt
T~ Bxport For rurbmes
i e
™ Inport For rurtimes shanng

T
S
ISwrbdw&Smbdl

T~ Enatle guides for 8-4kos ey

In the section marked, Linkage, choose a "Linkage ID" that has no spaces (and write it down to
remember it, you'll need it in a few moments), such as MyCustomParticle, then check the boxes
marked Export for ActionScript, and finally Export in First Frame:

~Linkage
Identifier: IMy”;ustomParticle

A5 2.0 class: I

Linkage: |V Export For ActionScript
I~ Export for runtime sharing
V' Export in first frame
I Import for runtime shating

URL: |

This prepares the symbol to be included in the Flash file. Press the OK button at top.

Flash now opens the Stage with crosshairs in the middle. At this point, you are "editing" the movie
clip. You want to bring in the images you made, in a sequence of keyframes. Click File > Import to
Stage, and go find your images:

CommandSim Fire: Instructor Edition, v1.5 41



l.od&l‘tlr_)m;ez 3 OF

e p|

copyEftectToClpboar,,. copyTaCipboard. pg s h components. jpg cshilrstaled jpg

CSEreClpsComes.jpg CSTemplstes. ipg

. ‘ ' |

Fla name: [custom png - Opan
Flasolpe |2 Formats =1 Cancel

and click on the first in the series. We recommend naming your graphics with a prefix then 1, 2, 3,

etc. because Flash will detect the sequence (once you press Open), and ask you if you want to load
the sequence:

Flash 8

\ ? ) This file appears ta be part of a sequence of images. Do you want to import all of the images in the sequel

Yes No | Cancel |

We answer "YES", and then Flash brings in custom1.png, custom2.png, and custom3.png, each in
their own keyframe:

5 10

1Y VY PRY PR PR PRY PRV PR PR P

P Layer 1

You will see that the images have been loaded into successive keyframes. You may want to adjust
the position of each image so it is aligned in the center of the movie clip (center of the crosshairs).
The Align tool (Window > Align) is very useful for aligning the graphics to the center of the Stage.
We have also added a label to each frame, so we can identify the particles in the plume.
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When you are finished with your placement, you can close the movie clip by clicking on the Scene 1

button label:

3 My d

80} s

= Scene 1

Your graphics will not be on the Stage, but will be in the Flash Library. The last step is to tell CS
Effects to use your movie clip from the Flash Library.

Specifying the Particle Movie Clip to CS Effects

If you don't have one there already, place an instance of CS Effects on the Stage and open the
Component Inspector panel. Go to the EDIT pane of this panel.
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_PREVIEW

USE EDIT SHARE CS EFFECTS

VERSION1.0

MAIN SETTINGS | ALLSETTINGS

VOLUMEVELOCITY DENSITY BRIGHT OVEEQLL

large

small slow . smmall

_|Show Numeric Yalue

it |1x

and then to ALL SETTINGS, PARTICLE, and pull down the drop-down box to set CUSTOM:

CommandSim Fire: Instructor Edition, v1.5

44



B X
' w Component Inspector E

2 CSEffects p*

Parameters Isindings | Schema I

VERSION 1.0

USE EDIT SHARE CS EFFECTS
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S } ALL SETTINGS
WIND | PARTICLE | DISPERSION FADE INOUT SIZE/SCALE
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Fireball
DarkGrey1

RELEASE RATE

- DarkGrey2

——————————

zparse LightGrey
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| | 1 |
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' TURBULENCE VARIANCE

| Show Numeric Yalues

Once you do this, the LINKAGE ID box appears:

|WND PARTICLE | DISPERSION FADE IN/OUT SIZE/SCALE

LIFETIME YELOCITY COLOR DENSITY PERFORMANCE

PARTICLE TYPE CUSTOM v

LINKAGEID |

RELEASE RATE
©®

Type in the name of the Linkage ID you assigned earlier. In our case, it was MyCustomParticle (note
there are no spaces allowed).

Click on the TEST MOVIE button, and you should see the following:
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If you see an empty screen, you have probably mistyped the Linkage ID you set before. You can
check the Linkage ID by opening the Flash Library (Window > Library) and then finding your movie
clip from the list (My Custom Particle):

B @ 4
i w Library - customParticleEx... i=
IcustomParticleExample.FlaEI = 3

5 items

u |
[ Mame |Type 2|
@ CSEffects Compile 0
[2:] customl.png Bitmapﬁ
@_J customz.png Bitmap -
@] custom3.png Bitmap

N My Custom Particle

880 @l | _'l—vJ

Right-click on the movie clip My Custom Particle and then select Linkage.... You will see a dialog box
with the Linkage ID you set, and you should ensure there are no spaces in the name, and that the
two check boxes are selected:

I e e s e 1 e T |

Linkage Properties i x|
e I B 1y CustomParticle QK I

AS 2.0 class: I Cancel

Linkage: ¥ Export for ActionScript
[~ Export for runtime shating
IV Exportin first frame
™ | Import far runtime sharing

LRLY |

If you continue to have problems, try posting on the discussion board or contact us and we will try
to help you.
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Programming CS Effects

You can use the CS Effects interface to create a virtually limitless number of effects. However, the
effect simply repeats its behavior until the movie ends. Real smoke and fire conditions improve or
degrade. Through programming, you can link a series of effects that show how the smoke or fire
evolves over time.

Important: We created CS Transition extension to help you make smooth transitions without
programming. However, we have included this introductory section on programming CS Effects for
those interested in technical details.

While we hope you can get the idea on how to program CS Effects from our samples, to fully
understand how to program in Flash requires a greater committment than reading these Help
pages. Going to your local library or bookstore, you will find many books at various levels of how to
learn Flash. Almost wherever you are on Earth you can find classes around you at local colleges,
training institutes, or through private companies. On the Web, there are thousands of sites devoted
to helping you learn Flash and techniques in Flash, such as FlashKit. Of course the most obvious
place to start is Adobe's own web site in the Flash Developer Center. Remember, you can also post
to the CommandSim discussion board with your Flash questions.

The following pages and samples describe how to write programs for your CS Effects so you can
make transitions or otherwise manipulate the tokens on the fly, while your scene is running.

General Programming in Flash: A very high-level overview of how to program in Adobe
Flash

How to Program the CS Effects Component: An overview and samples of how to manipulate
your smoke and fire while your scene is running

Parameter Reference: A list of CS Effect's controllable parameters and value ranges.

General Programming in Flash

While many books have been written about intricacies of programming Flash, if you have a technical
mindset, you can learn enough to control CS Effects instances by following the examples in the
distribution and these instructions.

Flash is a powerful graphics and animation engine that also has a powerful scripting (programming)
capability. For many things, you will want to use the visual, drag-and-drop interface to create your
movies. For more fine control, you will need to learn how to tell Flash to modify characteristics on
the fly, and this will involve programming. The term "programming" shouldn't scare you; we are not
writing equation solvers for systems of differential equations. Rather, we are just learning some
simple commands you use to communicate with the elements you have placed on your Stage.

The following pages are meant to give you enough information to start modifying CS Effects
instances your movies, not a tutorial on programming in general. Once you master the basics, you
can find other sources to learn more about Flash programming and begin to tap its vast potential.

Where Do I Begin?

The first step is to figure out where you are going to be placing commands. For the most part, your
commands will be placed on the Timeline.

The Timeline

The way to think about Flash movies is like regular movies: you create a series of images for Flash
to show over time. A movie is made up of "frames", and runs at a set "frame rate." By default,
Flash sets the frame rate at 15 fps (frames per second), which means that it executes 15 frames
each second. The picture below shows a frame rate of 24 fps.
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Frames of Your Movie

A "frame" can be either a keyframe, which is a new set of images you make, or a regular frame,
which just carries over any images you have already placed in previous frames. When you want an
image to appear at a particular moment in your movie, you create a keyframe at that moment in
the Timeline, and position and size the images appropriately. To make images stay on the screen
for more than an instant, you create a keyframe and the several regular frames following it. When
you want to change the image to the next, you create a new keyframe following those regular
frames.

Flash shows you keyframes by a circle graphic. That graphic is empty (white) if there are no images
in that keyframe; it is filled in black if there is one or more images or elements in that keyframe:

b o

An empty keyframe A keyframe with something in it

You will see when you create a new Flash document that Flash automatically creates a keyframe at
time position 1. If you want to add regular frames following position 1, choose the Insert > Timeline
> Frame menu option. Flash will add a regular frame following the first keyframe, and a rectangular
symbol will appear in the 2nd frame:

i | !

i Y

This rectangular symbol shows you the end of where the contents of the keyframe will be shown.
When you draw something on the Stage or bring in a photo, Flash will put it in the current
keyframe. The current keyframe (the one whose contents are being edited or added to) is the one
underneath the red vertical line (frame 1, in the picture above).

If you want to create a new keyframe, use the Insert > Timeline > Keyframe menu option. Then
Flash will create a new keyframe:

O
.

Tip: If you have multiple layers, inserting frames adds frames to the current layer. If you want to
insert frames for all layers, select the red box above the numbers in the timeline, then insert your
frames.

If you want to create some regular frames between your keyframes, click on the starting keyframe
(on the Timeline). The little keyframe will be highlighted. Then choose Insert > Timeline > Frame
(or in Windows, the keyboard shortcut F5). The keyboard shortcut in Windows for creating
keyframes is F6.
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You can only put images into keyframes, not regular frames. You will see when you insert a
keyframe, it will copy the contents of the previous keyframe into the new keyframe. If you don't
want to use those contents, instead of inserting a keyframe, choose Insert > Timeline > Blank
keyframe.

To summarize, you place images and other Flash elements into a keyframe if you want the images
to appear at a certain time. You create a series of keyframes to change the images over time.

Timeline Layers

Layers are used to separate content that would appear in the same frame. Layers let you control
the viewing order of things appearing at the same moment. If you have two overlapping images,
one on one layer and the other on another layer, the one on the top layer will be seen in its
entirety; the one on the lower layer will be only visible in areas not occupied by the image on the
upper layer.

You don't just put images into layers; you also put commands. While you can make your Flash
movies with only one Layer, we recommend you create a separate layer to hold the commands. Use
the Insert Layer button to create a new layer on the Timeline:

P Layer 1

454

v Insert Layer

We recommend that you change the name of each layer to something meaningful, rather than the
default Layer 1, Layer 2, etc. You can click on the dots next to the layer name to make it visible or
not visible (the eye), lock it (to avoid moving or editing the contents), and show the elements as
outlines (the box):

QQD}
P R -~

The Timeline gives the content for the movie. While a movie is running, Flash keeps track of the
current time position in something called the playhead. The playhead advances according to the
frame rate you set for your movie. You cannot change the frame rate in your movie once the movie
starts playing. When the playhead is on a certain frame, Flash shows the contents of all layers that
have frames defined in that moment.

We're now ready to put some commands in.

Our First Command

You only can put commands (called "actions") in keyframes, so if you want to execute a command
beyond frame 1, you need to make a blank keyframe for it. For example, let's make a command
occur at frame 12 (half a second into the movie, if the frame rate is 24 fps). We insert the blank
keyframe, then select the box:

Now we open the Actions panel (Window > Actions, for Flash Standard, Window > Development
Panels > Actions for Flash Professional). The Actions panel lets us type commands into that
keyframe.
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The first action we will learn is the "stop" action. This tells Flash to stop advancing the Timeline
(halt the playhead). Not particularly exciting, but very important. We might use stop if we wanted
to have some animation go on for a while, then stop the action. In the Actions panel, type the
words: "stop () ;"

Timeline | 5 Scene 1

i w Actions - Frame

iy
)
AN

ActionScript 1.0 & 2.0

Global Functions
ﬁ] Alab ' Piamaitaa

Important: Notice that when you have actions in a keyframe, Flash reminds you of this fact by
placing an "a" in the keyframe box.
Our Second Command

The second command we will learn is the output command (called trace). This is used only during
movie development, not once you distribute your movies. In the same keyframe as your stop
command, type the following text before the stop command: trace("Hello");

v P GvE QL

8l trace ("Hello™) ;
78 stop () ;

The trace command prints out a message to the Output window when the movie is running inside
Flash. You can test your movie (Control > Test Movie) to see that when the playhead reaches that
frame, the Output window will appear and Flash will print out that message. If you do not have the
stop command, your timeline will repeat when the playhead reaches the end, and you'll get the
message again each time the playhead passes that keyframe.

If you made a mistake in typing, when you go to test the movie (Control > Test Movie), Flash will
come up with the Output panel and tell you the problem, for example:
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1 trace("Hello

2 stop();

> | T

*AError®?® Scene=Scene 1, layer=Laver 1, frame=12:Line 1: String

literal was not properly terminated
trace ("Hello

' **Frror*? Scene=Scene i, layer=Layer 1, frame=12:Line 2: *)' or ',!
expected
atopi):

Go back and fix it before continuing. If all is well, you will get the following printed in the Output
window when you test the movie:

i w Qutput
Hello

Let's now learn some CS Effects commands!

CS Effects Commands

To give commands to CS Effects, you need to place an Effects token (called an "instance") on the
Stage, and give it an Instance Name. Typically, you will place the instance on keyframe 1. Select
the instance and open the Properties panel, and in the box marked "<Instance Name>" type in a
name and press Enter. For the first example, let's name the instance mySmoke.

The initial properties and characteristics of the instance are typically set using the interface. You can
change the properties as the movie is running by using programming.

Let's wait for 2 seconds and then change the smoke from light to dark black. Therefore, we are
going to create a keyframe at some point after the first frame (if your frame rate is 24 fps, 2
seconds is at frame 48. Check your frame rate by choosing the Modify > Document... menu item).
Create a new layer, click on the playhead (red) box, and insert a bunch of regular frames up to that
time point, then insert a keyframe.
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Important: if you have made a separate layer for your actions, as we recommend, make sure that
the layer with the instance has a frame at the same moment as where you wil place the actions. If

you place an action in a frame at a time point at which there is no instance, then the command will
fail because Flash will not know about the instance at that moment.

Select the keyframe and open the Actions panel. In the Actions panel, type the first command:

mySmoke.particleID = 0;

Let's break this down. The "mysmoke" refers to your CS Effects iinstance name. Make sure to get the
capitalization the same way you entered it into the Properties panel, since Flash is case-sensitive.
The dot (".") says "set a characteristic". The "particleID" is a characteristic that CS Effects defines
and allows you to change. The equal sign ("=") says to assigh the number 4 to the particle graphic
characteristic. If you look in the Reference pages, you will see that number 0 is a white laminar
smoke graphic. By default, the Effects instance will have skin 4, which is light grey laminar.

The smoke will start grey, and then after 2 seconds, it will change to white. Pretty neat!

This is the end of the programming demonstration. On the next page, we'll list all of the
characteristics you can set.
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CS Effects Parameter and Method Reference

You can modify any of the following parameters programmatically (listed in alphabetic order):

Parameter

Default
Value

Description

active

true

Boolean flag saying whether generator is
active. Set this to true or false to start or
stop the generator.

angle

270

Base direction (angle) to release particles.
For example, 270 is straight up, 90 is
straight down.

bright

100

Brightness of the particle (0-255).

brightChangeStart

15

How many steps before the end of the
lifetime that the particle starts changing
brightness. This feature is designed to allow
one to lighten or darken the particles as
they reach the end of their lives.

endFadeoutOpacity

Opacity value for particle when it reaches
the end of its fadeout period. The
generator fades the particle out from
fadeoutStart tothe end of its 1ifetime
using the difference of the particle
opacity value and
endFadeoutOpacity. For example, if
opacityis 100 and
endFadeoutOpacity is 0, the particle
fades from completely opaque to
completely transparent starting at
fadeoutStart and ending at the particle's
lifetime.

fadeinDone

10

When (in terms of 1i fetime) the fadein is
done.
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fadeinOpacity

Starting opacity value for fadein. Particle
will fade in from this value to the particle
opacity value over fadeinDone updates
(modulated by fadeinVariance).

fadeinVariance

How much variance (in terms of
1ifetime) to complete fade in of particle.

fadeoutStart

45

When (in terms of 1ifetime) to start
fading the particle out (lifetime minus this
number).

fadeoutVariance

How much variance (in terms of
1ifetime) to start applying fade out. The
fadeout point is determined from the base
fadeoutStart plus half of this value.

friction

Percentage of speed (100 == 100%) to
slow down particle after specified time
(frictionStart)

frictionStart

When (in terms of lifetime) to start friction.
Use -1 for no friction.

gravity

Amount of gravity to apply to each particle
per update. One can simulate friction using
this parameter by applying a small amount
and shooting the particles mostly in the
vertical direction).

heightScale

120

Height to scale the base particle.

initAcc

25

Number of steps (0 to lifetime) it takes to go
from O velocity to the set velocity. By setting
this to a non-zero value, it lets you
accelerate to the set velocity.

lifetime

80

Number of updates for each particle (the
particle's "lifetime"). The generator removes
the particle once it reaches the end of its
lifetime.
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lifetimeVariance

10

Produces randomness in how long a
particle is displayed. Each particle's lifetime
is set to the base lifetime plus or minus half
of this value.

opacity

85

How opaque the particle is, O (invisible) to
100 (completely opaque). Referred to as
density in the interface.

orient2spread

true

Rotate the particle in the direction it is being
released (release angle plus spread). This
parameter is not accessible through the
user interface--if you want to turn it off, you
have to set it programmatically.

particlelD

Linkage ID for the particles generated.

partPerFrame

0.175

Number of particles to release per frame of
animation, for example, 0.5 means release
1 particle every other frame.

partScale

120

Size to scale (percentage) the base particle
at the beginning. Size sets the
widthScale and heightScale to the
same value.

preCompute

80

Number of computations to apply before
first update.

randomXVariance

A random value used as starting x value for
the particle. Starting x value is chosen
between negative half this value and
positive half this value.

redrawInterval

40

How often (in milliseconds) to update the
visuals. A higher number will produce a
smoother result, but involve more
computation. This is respected if
updateOnFrame IS false.

scaling

What factor to use in scaling the particle per
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update, beyond the scalingStart
moment.

scalingStart

18

When (in terms of 1ifetime) to start
scaling the particle.

scalingVariance

How much to vary the scaling factor. A
particle's scaling is determined by the
scaling factor plus half of this value.
Determined on a per particle basis, not per
particle update.

sizing

100

Overall size of the plume (100 means full
size; lower number is smaller plume, higher
is bigger plume)

spread

20

Spread of dispersion to release particles.
For example, 20 means release particles
randomly within +/- 10 degrees of the
release angle.

startX

Horizontal (x) starting position of the
particle stream. This is a program-only
property that you can use to move the base
of the plume over time, for example, to
simulate a moving vehicle’s exhaust.

startyY

Vertical (y) starting position of the particle
stream.

targetBright

100

0-255. Setting this value makes a particle
start changing from the current brightness
to this value, beginning at the brightChange
update and beyond. The system computes
the brightness steps needed to achieve
this.

tintBlue

50

Amount of blueness to apply, if tinted is
true.

tinted

false

Boolean flag saying whether or not to tint

CommandSim Fire: Instructor Edition, v1.5

56




the particles.

tintGreen 50 Amount of greenness to apply, if tinted is
true.

tintRed 50 Amount of redness to apply, if tinted is true.

turbIncr 0 Simulates turbulence by assigning a
rotation (per update) for the particles. How
much to rotate each particle per update.

turbIncrVariance 0.87 How much to vary the rotation increment,
namely the turbIncr parameter plus or
minus half of this value.

updateOnFrame true Determines whether updates and redraw
happens each frame (default) or whether
the redraws happen at the redraw interval
(used to tune performance).

velocity 4.5 Velocity of particle, in pixels/update.

velocityVariance 1 Produces randomness in how fast each
particle is traveling. Each particle's velocity
is set to the base velocity plus or minus half
of this value.

widthScale 120 Width to scale the base patrticle.

wind 0 Wind direction and strength. A number that
is the x-offset to add for each update.

windAcceleration 5 How quickly the wind accelerates to reach
its set strength (wind).

windStart 30 When (in terms of 1ifetime) to start
applying the wind value.

windStartVariance 0 Variation on when to start the wind.
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zOrder true If true, the system places new particles in
front of the old particles, giving the
appearance of the smoke drifting away from
the screen. If false, it places new particles
behind old particles, to give the appearance
of the smoke coming toward the viewer.

CS Effects exposes the following methods:

Method Description

fastForward (steps) Update the particle stream by steps updates.

getParametersString Retrieves the effect code from the CS Effects
instance.

resetStream() Clear all particles and re-start generator (if already

started, otherwise, leave it stopped but cleared)

setParametersByString | Sets the instance effect to the effect code passed
in. The effect code is produced in the CS Effects
user interface, with the first and last elements

removed.
startStream() Start the particle generator.
stopStream () Stop the particle generator.
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Chapter 4
CommandSim Transition (CS Transition)

Smoke and fire conditions can change due to many factors, including materials consumed, new fuel
sources, and effects of water applied. CommandSim Effects ("CS Effects") lets you model each
'state' (condition) of a smoke or fire plume, but does not help you transition among the various
states to achieve a realistic-looking lifetime of that effect. CommandSim Transition ("CS
Transition") is a Flash extension that helps you control the timing and appearance of smoke and
fire in your scenario, across different state changes.

One of the advantages of using the approach we do for CS Effects is that it enables us to smoothly
change parameter values over time, thereby transitioning from an old to a new effect gradually, just
as it would in real-life (try out the transition in the figure on the right). This provides for a much
more realistic experience than suddenly changing the parameter values and producing a noticeable
change from one effect to the next. What's more, you can use CS Transition to fade-in and fade-
out/hide any movie clip, so you can orchestrate all the elements in your scene to occur based on
your set trigger (keystroke, mouse click, time sequence, etc.).

With the introduction of CSStateManager, described in the section on CS State Manager, you can
now also group your transitions into "states" (fire conditions), and have the current state preserved
across multiple Flash movies. See the section on CS State Manager for more information.
Overview of Use

To set a smooth transition from one effect to another, you simply

1. Place a CS Transition token from the Components Panel onto the Stage

2. Tell it which CS Effect or movie clip instance to modify

3. Give it the ending effect parameters you want to set

4. Indicate how the transition should be triggered, i.e., what action the user must take to

initiate the transition, whether keystroke, mouse click, time sequence, or state change (for
CommandSim Fire Department Edition).
Organization of Help

The following sections describe how to use CS Transition to sequence how your effects change over
time. It is organized as follows:

1. Quick Start Guide. Make your first effect transition within 5 minutes

2. Using CS Transition. The variety of effect transitions you can produce and where to enter
the settings on the user interface

= Start Effect Settings
= End Effect Settings
. Transition Parameters

3. Parameter Reference Guide. Guide to changing settings for a CS Transition
programmatically (Advanced)
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CS Transition Quick Start Guide

As our quick-start example, we are going to make a transition that goes from grey turbulent smoke
to dark black turbulent smoke over a short period of time, then reset the effect by pressing the
RIGHT ARROW key. The Flash file is located in the examples folder on the distribution CD.

1. Open Flash and create a new Flash document (or use one of the CommandSim templates).

2. On the Stage, load any background picture by choosing File > Import to Stage..., and then find a
background picture you want to use.

3. Open the Components Panel (Window > Components). If the CommandSim folder is collapsed
(plus sign on its left), click the plus sign to open it.
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4. Drag an instance of CS Effects to the Stage.

5. The first thing we'll do is to give the CS Effects instance a name. Open the Properties panel
(Window > Properties), and while the CS Effects token is selected (outlined in a blue line), enter the
instance name "smokel" into the box containing the words <Instance Name>.

|| Instance of:  CSEffects

SWan I

%if 308.3
y:| 161.3

6. By default, the CS Effects will be a grey laminar/turbulent pattern, but let's use the Light Grey
Turbulent effect in the Turbulent Smoke folder. Open the Component Inspector panel and, in the
USE tab for the CS Effect instance, select the Light Grey Turbulent effect.
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We want to create a new transition and set its target to black turbulent smoke. Open the
Component Panel (Window > Components) and find the CS Transition token inside the
CommandSim folder. Drag it anywhere onto, or off of, the Stage. It will remain hidden during movie
playback even if you place it on the Stage.

7. With the CS Transition selected, open the Component Inspector Panel.

25 TIANIITIN
MERADN L)

TRANSONIDENTIFIER [ |
meTancename [ ]

START  END | TRAMSION

EFFECT  EFFECT | PARAMETERS

WHERE LFFECT SETTINGS START FROM:
* Stantdam Cunent Erfect Gettmge
Ettect Coda Sel Effent
on

FAATE M AR

HOW TO TIIGGER TRANSITION:

Kaystshn  Type ey in bes: | o D
- wat e Dp«s;

Buttes iretance sam
* Time fom daf e’
stae P ,

—_

8. If the panel is too small for you to read, you can move your cursor to one of the corners, and
click and drag the corner to enlarge it. In the box marked INSTANCE NAME, type in the instance
name of the CS Effect token we placed, smokel (make sure your upper and lower case are
consistent--it matters to Flash).

O YHANSITION

VERSKN YYD

TRANSITION IDENTIFIER
INSTANCE NAME smoka|
START END TRANSITION
EFFECT EFFECT PARAMETERS

WHERE EFFECT SETTINGS START FROM:
o Start horn Curert Effect Sattings

Effect Code Set ESect
OR

PASTE IY N pOx
HOW TO TRIGGER TRANSITION:
Kaystroke Type keymbox | v :]
o adways wait foe D press
Button mstance name

o, Time from stan (secs} 10

State |o

9. Since we want to start with the original (grey) pattern, we want to leave the WHERE EFFECT
SETTINGS START FROM to be "Start from Current Settings". In the area marked HOW TO TRIGGER
TRANSITION, we want to mark the circle next to TIME and enter the value 5 (seconds). The
transition will wait approximately 5 seconds before making the transition to the new pattern.
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10. In the END EFFECT tab, we will now tell the transition to go to the black turbulent smoke. Click
on the END EFFECT tab, then on the button marked SET EFFECT.
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11. When you click on this button, the familiar CS Effects interface will show up. However, you will
notice that the typical TEST MOVIE button, usually on the bottom left, has been replaced by two
buttons, APPLY and CANCEL:
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12. You select/edit the effect you want to use as the end result. In our example, choose the Black
Turbulent smoke in the Turbulent Smoke folder. Then press the APPLY button. This locks in your
choice. If you do not want to change the setting you chose previously, press CANCEL.

13. When you return to the Transition interface, you will notice that the system has placed the

effect code into the box underneath the SET EFFECT button. If you prefer, you could have cut-and-

pasted an effect code into the box, bypassing the SET EFFECT process.
Hide / Fade out Effect

« End CS Effect Code | gt Effect

OR
96,10.2,0.175,5.292,

PASTE ITIN BOX

14. By default, effects are set to transition over a 10 second period. You adjust the period in the
TRANSITION PARAMETERS tab. If you want, click over there and set the transition duration to 3
seconds.
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15. Test your effect by clicking on TEST MOVIE. Once you wait 5 seconds, the transition will kick in
and make the change over the next 5 seconds.

16. Once the transition has happened once, it will not occur again. If you want to restart the
transition, you need to place a RESET transition. Let's do that now. Place another CS Transition onto
the Stage and set its instance name to smokel (same token). You can have multiple transitions
apply to the same CS Effects token or movie clip.

17. In the area on HOW TO TRIGGER TRANSITION, click on KEYSTROKE. Since we want to use the
RIGHT ARROW key to trigger the reset, pull down the combo box marked "Type key in box" and
choose RIGHT ARROW.
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18. Lastly, let's set the RESET functionality. Go to the END EFFECT tab, and choose the Reset Effect
button. Test your movie by pressing the TEST MOVIE button, or Controls > Test Movie. You can
press the right arrow key at any time, but if you do it after the first transition has occurred, you will

see the effect go back to the original grey smoke.
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Congratulations! In future pages, we will examine the CS Transition functionality in more detail.
Again, this example FLA is located in the examples folder on your distribution CD. It is called
firstTransition.fla.

Using CS Transition

The Quick Start example showed how to make a transition based on time, and how to make a
transition that reset the look of a CS Effect pattern. CS Transition has many more features that
allow you to construct transitions over the lifetime of a particular effect or movie clip. Each
transition can trigger one event, but you can create multiple transitions that affect the same
instance, or multiple transitions that affect different instances with the same trigger, such as
pressing the right arrow.

One of the basic ways to use CS Transition is like the Quick Start Guide example -- set up all your
effects on the Stage at first, and then at some future moment, trigger transitions by time elapsed or
button/keystroke press. You can make the effects or movie clips hidden at first by telling them to
Hide at time 0.

At the top of the panel you use to define the transition (in the Components Inspector Panel), there
are two fields:

1. Transition Identifier: This is text you type in that is displayed on the transition on the
Stage. The idea is that you can put a label telling yourself what the transition does, so you
don't have to open the Component Inspector panel to determine that. We envision you will
have several CS Transitions on the Stage at once, so you can label each with an appropriate
message. For example, you might label the transition you make to reset an effect "Reset
Smokel Effect". You might label a transition that changes smokel (instance) to black on
pressing the 1 key "Change smokel to black on 1". The label can help you identify the
function of each transition.

2. Instance Name: This is the instance name of the CS Effect or the movie clip. You assign
the names by selecting the item and entering the name into the appropriate box in the
Properties panel. A common mistake in making a transition is to forget to enter the instance
name.

Previewing and Testing Your Transitions

The panel on the left of the interface can be used to preview your transition by pressing the
PREVIEW button. Pressing TEST MOVIE does the same as Control > Test Movie, which creates the
SWF movie file and shows you the results. The PREVIEW is of somewhat limited usefulness typically,
since it cannot show you the start effect unless you enter the code into the Start Effect Code box.

Tabbed Panels

The ways in which you can control the transition are broken down into how you can start/trigger the
event, and what the effect/movie clip transitions into. For convenience, we have broken these
decisions down into individual panels in the user interface.

Start Effect. You can tell the system to start from the current settings of the effect, or give
the transition a code to set when the trigger is fired. Most of the time, you will tell the system to
start from the current settings. You need to also specify what will trigger the effect to start. The
options are:

= keystroke. When the user presses a key.
=  button press. When the specified button is pressed.
= time. When the time (in seconds) elapses.

= state. When a state change is triggered. States can be defined using
CSStateManager, to enable persistent fire conditions across multiple Flash
movies, or in the multiplayer CommandSim Fire Department Edition.
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= End Effect. The options here tell the system what the effect or movie clip should look like
when the transition is finished. If you want to transition a CS Effect, you most likely will
specify the CS Effect code to use as the target. For movie clips or even CS Effects, you can
have them fade in (to 100% opacity) or fade out (to 0% opacity). You can also specify that
the transition should RESET the triggers and behavior of the CS Effect.

Transition Parameters. Parameters that dictate how aspects of the transition are
accomplished, for example, the duration of the transition, and how often to update the effect
during the transitional period.

The next several sections describe these panels and values in more detail.

Start Effect Tab
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The Start Effect tab controls two aspects of the transition:

1. What effect to use in starting the transition. You have the option of starting the effect
(when the transition is initially triggered) from the current settings of the CS Effect, or
specify an effect code string (one copied from the CS Effects SHARE panel) to use as the
effect starting point. Normally, we imagine you will leave it set at "Start from Current". If
you do specify an effect (either by pressing SET EFFECT, adjusting the effect in the Effects
interface, and pressing APPLY, or by pasting the effect code into the box), then when the
transition is triggered, the transition will set the effect into the instance given in the
INSTANCE NAME field. If your instance is not a CS Effect, you just want to leave this setting
as Start from Current.

2. How to trigger the transition. You have many options in how to trigger the transition. The
options are:

a. Keystroke. You can specify a keystroke, such an alphanumeric or special
character, or select a special key from the list (for example, Space, arrow keys, Page
Up, etc.). Keys such as ESC (Escape) or TAB are not permitted. The field marked
"Wait for X presses" is a described below. To select a key, make sure the drop-down
menu is set to "Type a key", then enter the (single) key in the box on the right. If you
want to select a special key, choose it from the drop-down menu. The box for entering
a keystroke will disappear.
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Note: alphabetic keystrokes are case-sensitive.

b. Button instance name. If you specify the instance name of a button or movie
clip, the transition will be triggered when the user presses that button, specifically the
number of times given in "wait for X presses" (below).

C. Time. Enter a time, in seconds, and the transition will be triggered when the time
elapses.
d. State. This is for state changes you make with CSStateManager or CommandSim

Fire Department Edition scenarios. For the Instructor Edition (CSStateManager), you
organize your transitions into states and then use a CSStateManager to trigger the
state change. State changes are preserved across multiple Flash movies. For the Fire
Department Edition, you can specify the state index (0 is first state). When the
instructor puts the system in that state, or you enter the visual and the current state
is that state, the transition gets triggered. By default, when the visual first loads, the
system checks the specified state to see if it should trigger the transition. In this way,
the system automatically sets up the state when the visual is first loaded.

Note: you can indicate this transition is appropriate for multiple states by separating
the state index (number) by a comma, for etwampl e,

mean fAtrigger the transition on states 2, 3 or 40.

Explanation of Choice between "Always" and "Wait for X presses"

This feature ties the transition to a specific number of presses of a keystroke or button press. For
example, you may want one set of changes to occur when you press a key one time (like and arrow
key), and a different (more involved) condition when you press it again. You can set up one
transition to be triggered on the first press, and a different transition on the second or subsequent
press of that character. Therefore, for each transition triggered by a keystroke or button press, you
specify exactly which number of presses achieves that effect.

If you want to change the effect every time you press that key, you select the ALWAYS option
(selected by default).

If you want to repeat the sequence of effect changes, you can create a RESET transition (described
in the next section on End Effect), and when that transition is triggered, the humber of recorded
key/button presses gets reset to 0, so pressing the key or button will re-activate the transition
when the number of presses is reached.

Programmatically Initiating a Transition (Advanced)

If you are familiar with Flash scripting, you can trigger a transition by invoking a method of the
transition instance. The transition method is called startEffectTransition. Therefore, if you want
to trigger the transition programmatically, use the following example:

myTransl.startEffectTransition() ;

in which myTrans1 is the instance name of your transition.
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The End Effect tab is used to tell the transition what to do by the end of the transition period, for
example, fade-out, change to another effect, fade-in, etc. If you want to transition from one effect
to another, you specify the end effect code (derived from the SHARE panel in the CS Effects user
interface), and the CS Transition smoothly interpolates the values. The possible options are
presented here.

END CS EFFECT CODE Transition

The most common type of transition will be the transition from one CS Effect setting to another. If
you are transitioning these effects, you will want to set the end effect to this option.

You set the target (end) effect most simply by choosing SET EFFECT and then using the CS Effects
interface to set your target effect:
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When you have finished setting your effect, press APPLY. If you do not wish to lock in your changes,
press CANCEL. Either way, you will return to the CS Transition interface.

When you get back to the CS Transition interface, you will see the effect code in the box. If you
prefer (though we don't know why you would), you can paste an effect code into the box instead of
visually editing your effect with SET EFFECT.

FADE-IN Transition

If you want to have your CS Effect or movie clip fade-in, it is assume that the starting point is with
the instance hidden (which you can do with the HIDE/FADE-OUT setting prior to invoking the FADE-
IN trigger). The effect or movie clip will fade-in gradually over the transition duration (specified in
the TRANSITION PARAMETERS tab). How smooth the fade-in occurs depends on the smoothness
setting, also present in that tab.

If you apply a fade-in transition to a movie clip instance, CS Transition will issue play () at the
beginning of the transition duration.

HIDE/FADE-OUT Transition

To have a movie clip or CS Effect fade out, that is, reach full transparency, you select this option. If
your instance is a CS Effect, when it gets hidden, the Effect plume is also reset. The movie clip or
Effect is gradually made more and more transparent, until it disappears (fully transparent). The
amount of time it takes to disappear, and the smoothness, are controlled in the TRANSITION
PARAMETERS tab.

If you want to hide the instance immediately on loading, set this to Hide / Fade Out, specify O for
transition duration (in TRANSITION PARAMETERS tab), and set the trigger to Time with a value of 0
seconds. If you apply a fade-out transition to a movie clip instance, CS Transition will issue stop ()
at the end of the transition duration.

"Reset Effect Instance" Transition

If you are delivering instruction, you may want to roll your scenario back to the starting point and
re-initiate the transitions. By setting this transition to RESET, when it is triggered, the CS Effect
instance is rolled back to the starting point, and the transition triggers are reset. For example, if the
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first right arrow keystroke activated a trigger, after a reset, pressing the right arrow key will re-
activate the trigger.

You only need one Reset transition per instance. Therefore, if you have several CS Effect instances,
you'll need one reset transition for each instance.

IMPORTANT: Any Reset Transition should be added to the Stage after any other transition for that
CS Effect. If you encounter the situation in which your first triggered transition is occurring at the
same time as your reset, cut the reset instance from the Stage and paste it back in.

If you apply a reset transition to a movie clip instance, CS Transition will call a method "reset". You
would have to define that method to reset the movie clip--it won't do anything by itself. If you
apply the reset transition to a CS State Manager, it will reset its timing and number of key presses
seen already.
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This tab contains transition parameters for determining important aspects of the transition.

Transition Time. This is the duration of the transition, in seconds. A 0-duration transition
happens immediately, i.e., goes directly to the end effect or fade-in/fade-out/reset.

Transition Smoothness. This determines how often to update the effect or movie clip
during the transition. Values close to SMOOTH make more frequent updates; values close to
COARSE make less frequent updates.

Switch Particles When. When you transition between effects that have different particles
(graphic puffs), you tell the system at which point in the transition to switch over the particle. If
you choose a value close to START, it will change the particle close to when the transition starts.
If you choose a value close to the END, it will change the parameter close to when the transition
is finishing.

Ignore 'Overall Size' Changes. The start and end effect codes may have different
'Overall Size' parameters. The Overall Size controls the scale of the effect. If you transition
between effects that have different scales, the transition will gradually change from the start
overall scale to the end overall scale. This will almost necessarily cause the effect to jump as it
changes its overall scale factor. Therefore, we added an option by which you can say to ignore
the overall size in the start and end effect -- just use the overall size in the start effect. The
easiest way to understand this is to try unchecking the box and see the resulting transition,
comparing it to when the box is checked.
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CS Transition Reference (Advanced)

The CS Transition can be addressed programmatically (through scripting) if you like. This extension

exposes the following parameters:

Property Name Default
Value

version 1.1.0

eName

startEffect "code"

startEffectCode

startTrigger "time"

startEffectTime 10

startEffectkey

startEffectButton

endEffect "code"

endEffectCode

Description

Current version of the extension.

Effect instance name

String indicating what effect code to use for the
start. Possible values are "current" or "code"
(lowercase)

The CS Effects code to start the transition with.
Empty if you start from the current settings. The
code is two elements shorter than the CS Effects
code -- there is no effect name (first parameter of
CS Effects code), nor folder name (last
parameter).

What triggers the starting of the transition. A
String that can be "key", "click", "time", or "state".

Default time, in seconds, to trigger the transition.
Only used if startTrigger is set to "time".

The keystroke used for the trigger, when
startTrigger is set to "key". If this is a String, it is
1 character. If it is a number, it is the KeyCode for
a special key (such as arrows, Page Up, etc.) given
in the Key instance.

Instance name of the button that triggers the
transition. Only used if startTrigger is "click".

Tells what the end effect should be. Possible
values are "reset", "fadein", "fadeout", and "code".
Must be lowercase.

The CS Effect code to end the transition with. Only
used if endEffect is "code". The code is two
elements shorter than the CS Effects code -- there
is no effect name (first parameter of CS Effects
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transDuration

transSmooth

switchPartWhen

IDString

ignoreOverallSize

waitPresses

stateTrigger

10

0.2

Transitions
<eName>

true

code), nor folder name (last parameter).

Duration, in seconds, of the transition.

This tells the transition how often to update the
transition settings between the start and end
effects.. A number between 0 (ultimate
smoothness) and 1 (ultimate coarseness). Do not
set this value to 0, but use a number like 0.01 as
very smooth.

When to switch the particle (graphic) of starting
CS effect to the particle of the end effect. A
number between 0 and 1. 0 means at the
beginning of the transition, and 1 means at the
end. A number in between means switch at that
point.

The identifier label used to mark this transition
during authoring. Used to help the developer
recognize which transition is which.

Tells the transition to ignore the Overall Size
parameter in a CS Effect when transitioning from
the start code to the end code. If set to true, the
transition leaves the Overall Size parameter the
same as the start effect code's Overall Size
parameter.

Number of times to wait for key or button presses.
If the value is -1, then it means to trigger the
transition every time the key or button is pressed.

Which state to change to when the transition is
triggered. This is numeric by convention, but does
not have to be.

The extension exposes the following methods:

reset () : Call this to reset the effect (if this transition is set to be a reset transition)

startEffectTransition () : Call this to trigger the transition programmatically

terminateTransition () : Call this method to terminate the transition immediately.
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Chapter 5
CS State Manager

So far presented, the tools let you mock up a single visual with a variety of smoke and fire
conditions. However, in practice, you often need the ability to look at a scene from various views to
determine the appropriate course of action.

If you are only creating a single view, you only need to use CS Transition -- the CS State Manager
persistence does not help you.

The CS State Manager lets you group a set of conditions into what we call a "state". With that
group, you can invoke all those changes at once. You can already do this with CS Transition by
using the same trigger (pressing 1, for example). However, if you were to show a new visual (file),
such as from different sides of a building, you cannot use CS Transition to preserve the condition in
the new visual. The CS State Manager lets you preserve the condition as you move from one file to
another.

(THIS EXAMPLE IS ACTIVE IN THE LIVE HELP DOCUMENTS AND IN THE COMMANDSIM SUPPORT
SITE) This is easiest to demonstrate by example. Look at the picture below. We have mocked-up
two sides of a building (sides A and B), which show smoke coming out of side C (rear). We have
defined three states: no fire, smoke showing, and fully-involved. You invoke the states by pressing
0, 1, or 2, respectively (you can assign arbitrary keystrokes or timing).

Click on the arrow to start. In the side A (front) view, you can see light smoke from the rear of the
building. If you press the 0 key, the smoke will disappear. If you press 2, it will get worse (black).
You can press 0, 1, or 2 as much as you would like. If you press the arrow key to move to side B,
you will see that the smoke conditions are similar on side B. On side B, you can also press 0, 1, or 2
to change the conditions, and when you move back to side A, the conditions will persist. These
examples are in the Samples folder in the distribution, under the folder State Examples.

Using CS State Manager

To help sort out where to start in the overall task of scenario creation, we developed a process
described in the section titled "Scenario Creation Process." Part of the process is to define the
number of states you will have, and then using one CS State Manager for each state in each file.

The CS State Manager component is located in the CommandSim folder in the Components panel
(Window > Components). Drag a cSStateManager token onto the stage. On the Stage, the CS State
Manager will be represented by an orange box with black text inside (below, left).
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When you select the CS State Manager instance and open the Component Inspector, you will see
the CS State Manager interface (above, right). The options are:

IDENTIFIER: What you type in this box is placed in the box on the Stage to help you
locate which state manager manages which state. If you leave the box empty, by default CS
State Manager will write "Stage Change <State: <state number indicated>>" in the box, as
shown.

STATE NUMBER: Which state number this represents. Typically, the state number is an
positive number, however, you can put whatever text you like here (no spaces or punctuation).
You will put this state humber (or text) into the state box in the CS Transition interface, for
transitions you want to associate with this state.

MAKE THIS START STATE: If this box is checked, then the CS State Manager sets the
state of the simulation to the specified state number when your movie starts. As the Scenario
Creation Process explains, you should use this once in the beginning of your simulation to reset
the state to a predictable state. If you do not, whenever you start your simulation you will
encounter whatever state was last set when you ran your simulation, even if that state was set
hours, days, or weeks ago.

TRIGGER STATE CHANGE ON: You decide how the user will trigger the state change. The
options are by keystroke (single character, or special character such as the arrow keys, page
up/down, delete, etc.), by button press, and by time.

. Keystroke: You select the keystroke that will invoke this state change. If you want
to use an alphabetic character or number, select "Type key in box" from the drop-down menu,
and type in the (single) character in the adjoining box. If you want to use a special character
(Left/Right/Up/Down arrow, Enter, Space, Tab, Delete, Page Up, Page Down), select the
character from the drop-down menu. Make sure that Keystroke is selected (the radio button to
the left of the word Keystroke should be clicked on).

By default, the keystroke you use will invoke the state change every time you press the key. If
you want the change only to be invoked on a certain number of presses, type the nhumber of
presses in the box next to the label "wait for". You might want to do this if you decide to use
the same key to increase or decrease the state, for example, Up arrow to increase the state
and Down arrow to decrease the state. However, once you press the key the specified number
of times, that state cannot be triggered again unless you restart the simulation or use a CS
Transition and specify RESET for the CS State Manager instance.

= Button Press: You can make the state change when you click on a Flash button or
movie clip. To do so, enter the instance name of the button or movie clip in the adjoining box.
Make sure that Button Press is selected (the radio button to the left of the word Button Press
should be clicked on).
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By default, pressing the button will invoke the state change every time you press the button.
If you want the change only to be invoked on a certain number of presses, type the number of
presses in the box above Button Press and next to the label "wait for". You might want to do
this if you decide to use the same button to increase or decrease the state. However, once you
press the button the specified humber of times, that state cannot be triggered again unless
you restart the simulation or use a CS Transition and specify RESET for the CS State Manager
instance.

= Time: To make the state change automatically after a certain number of seconds,
enter the number of seconds in the box adjoining the word Time. Make sure that Time is
selected (the radio button to the left of the word Time should be clicked on). The state change
will occur after the number of seconds you indicate has elapsed. Once the time has elapsed,
that state cannot be triggered again unless you restart the simulation or use a CS Transition
and specify RESET for the CS State Manager instance. If you have MAKE THIS START STATE
checked, the time is ignored and the state is changed when the movie starts.

Once the time has elapsed and the change has occured, that state cannot be triggered again
unless you restart the simulation or use a CS Transition and specify RESET for the CS State
Manager instance.

CS State Manager Reference (Advanced)

The CS Transition can be addressed programmatically (through scripting) if you like. This extension
exposes the following parameters:

Property Name Default Description
Value
version 1.0.0 Current version of the extension.
stateIndex State index number to set
stateChgTrigger "click" String indicating whether the state trigger is time,

button (movie clip) press, or keystroke. Possible
values are time, click, or key.

stateChgKey If stateChgTrigger is key (keystroke), this variable
gives the specific key used to trigger the state change.

waitPresses -1 How many times one has to press a key or button to
invoke this state change. -1 means invoke the change
every time the key or button is pressed.

stateChgButton " The instance name of the button or movie clip you
want to use to trigger the state change, when the
button is pressed. This is not used if the trigger is a
keystroke.

IDString This is the message shown in the box on the Stage
during authoring. If the value is blank, the system
puts the message "State Change <State: <state
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number> >",

resetToState false If true, change the state to the state specified
(stateIndex) when this extension loads. This is used to
initialize the state to a predictable value before
starting a simulation.

The extension exposes the following methods:

reset () : Call this to reset the timing and number of keystrokes/button presses counted so
far. Used when waitPresses is not -1.

changeState () : Call this to trigger the state change programmatically.
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Chapter 6
Picture Scroller

Flash gives you the ability to shrink or enlarge images to whatever size you need. If you have a
picture of a large area, you may not want to shrink it all to fit on the screen at once because it
becomes difficult for the viewer to see all the detail. From a training perspective, you may want to
teach people to look in various directions, rather than merely seeing things all in front of them at
once.

The Picture Scroller component lets you decide how much of the visual to show in one screen-full,
and provides an easy way for viewers to pan across the whole picture to simulate looking left, right,
up, or down (depending on how much of the image is not visible at once).

To make creating scrolling pictures as easy as possible, we have provided a template you can use to
base your visual on. Once you gain comfort with the Flash authoring environment, you can
configure the scroller in different ways, such as scroll rate, border sensitivity, initial view position,
and several others.

The scrolling picture below gives you the best idea of what the picture scroller does. All you need is
an image you want to scroll!

How to Use the Picture Scroller Template

The CommandSim Fire: Instructor edition distribution includes templates (base Flash documents)
that simplify performing certain tasks. For example, on this page, we will show you how to use the
template for the picture scroller. You can use the picture scroller without the template, but you
should be familiar with using Flash components before doing so. These templates are installed into
Flash when you install CommandSim Fire.

Steps to Make a Scrolling Picture

1. Before you begin, find a photograph you want to use as the scrolling background. This
photograph should be larger than 640x480 pixels or else there will be no scrolling
necessary!

2. One template included in distribution is called Basic Scrolled Image. When you first open
Flash, you need to click on the CommandSim folder under the heading "Create from
Template." If you do not see this folder, you have not installed CommandSim Fire properly.

As the description reads, the Basic Scrolled Image is a template with a scrolling picture
element provided by default:
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3. Click OK and Flash will open with the picture scrolling elements already embedded. The
Instructions will be displayed prominently:

= |
ré load @ e s ek e €

L 4
Wew

' Q °
tders Instructions:
rz
1y 1. Right-click on this text to bring up a menu

o 2. This text is a placeholder for the photo you will use, so
: you need to edit the placeholder. Press "Edit in Place"

r‘ 3. Import your photo onto the Stage (File menu > Import >
€ of Import to Stage)

4. Align the top-left corner of your photo to the small
crosshairs you will see in the top left. If you do not see
the crosshairs, use the scrollbars to move the view of
the Stage

5. Save your movie (File > Save)

5. Test the movie (Control > Test Movie) and you're done!

4. We will follow these steps in this tutorial. Right-click over the instructions and choose the
Edit in Place menu entry.
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Actions

Bring in a photograph by choosing the menu File > Import... > Import to Stage. When the
photograph comes onto the screen, click and drag on the photograph to align its top-left
corner with the top left corner of the Stage, indicated by a small crosshairs icon. In the
figure below, we have not aligned them yet.
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2 Layer 1 « @@

Yihed dr || ¢ ol wm et [2406s | 00s

Top-left of picture

Top-left of
gtage

2

Optional: After you've gotten the hang of moving a picture around, you can try out Flash's
alignment tool (Window > Align menu) that can help you align graphics precisely, either to
one another (all those selected), or to the Stage. In our case, we could select the picture
and align it to the top-left of the Stage.
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You align things to the Stage by selecting "To stage:" and the element you want to align,
then you click on the button indicating how to align those elements. For example, top-left is
the first graphic below "Align" (which is align to left border), and the fourth graphic on the
same row (which is align to top).

Once you have aligned your photograph to the top left corner, you're all done!

Save the movie (File > Save). When you save the movie, if you are using Flash 8, you will a
message asking if you want to save it in the new format (since the template is in Flash MX
2004 format, for backwards-compatibility):

= Flash B Compatibility

This Hle wil be converted from a Flash M 2004 or older format to
Flash @ farmat, You wil not be able to open it in a previous
version of Flash,

To sava this flie In an older format, choose the Save As...'
command,

o K

Press the Save button. Now test it (Control > Test Movie).
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When a picture is larger than the Stage, the picture scroller does not tell the viewer it can
scroll -- he or she must move the cursor to the border of the picture.

Advanced: The picture scroller can add a note to let viewers know they can look left, right,
up, or down. Those are the white rectangles you see above (we call them "text cues"). Here
is a closeup:

On the next page, you will see how to control this as well as all of the scrolling pictures
parameters, such as scroll speed, initial position, border width, etc.

7. Because you saved the movie, Flash will create an SWF (distributable) file in the same
folder as the source file (FLA). If the people you are distributing it to do not have Flash, you
can click on File > Publish to create an HTML page that accompanies and displays the SWF.
For PowerPoint, you will include the SWF and do not need an HTML page.

8. Click on the tab that says Scene 1 (next to the words Timeline) and you will finish editing
your scrolling view.

If you want to change the picture, or you have just entered Flash and opened the document
you saved, right-click over the picture and choose Edit in Place (as in Step 4). Once you are
now editing the picture, you can delete it (select it and press the Delete key), and you can
then import a new picture.

Adding Smoke and Fire into your Scrolling Picture

When you issue Edit in Place, you are actually editing what Flash calls a "movie clip". The movie clip
contains your photograph and the instructions. You can place other things in the movie clip, such as
MXinferno generators. In this way, the smoke will stay exactly in place when your viewers scroll.

Configuring Picture Scroller Properties
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The Picture Scroller lets you control properties relating to how fast the picture scrolls, how much of
the border is used to activate scrolling, and the starting position of the photo. You can either use a
template to create a scrolling picture, or you can set it up manually by clicking and dragging a
Picture Scroller component from the CommandSim folder in the Components panel (Window >
Components, or, for Flash MX 2004 Professional, Window > Development Panels > Components):

= |l '_
S 0D 8 -3 db

i w Components i

= @ Commandsim
R " ;gj 360 Degree Panorama Scr...
A () csEffects Generator

~[J inset backward btn

[ inset down btn

~[] inset forward btn

[ inset left btn

-[J inset right btn

[ inset up btn

j ~[J Mavigation Arraw

» c & set CommandSim file path
# @ Commandsim HazMat

I # & FMXIS Components

If you do the latter, you need to align the component with the top-left of the Stage. You bring in a
photo and convert it to a movie clip with the registration point in the top left corner. Then you give
your movie clip an instance name (in the Properties panel), for example, myPhoto:

© W properties  Parameters

E iMovie Clip v || Instance of:

' myPhata || [swap... |
¢

8000 |w|00 |

LU
You will tell the Picture Scroller this name under the "view clip" property.

Note: if you want to show a smaller region to scroll, you can scale the Picture Scroller component
to the viewing size you want. Simply use the Free Transform tool (main toolbar, square with the
dots on it).

What Did We Do by Using a Template?

If you came into this page from the previous one, you might be wondering what we actually did in
using a template. We used a template that already had the picture scroller in it. If you look at the
structure of the Flash document, you will see that we made the template with a picture scroller
component and created a movie clip called photo. We placed the picture scroller on one Layer, and
the image (photo movie clip) on the other:
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When you issue "Edit in Place", you are editing the photo movie clip. If you click on the dot
underneath the eye (on the image layer), you will now see the actual pictures scroller component (a
block with a series of text -- instructions):
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o< of Mavie Clip{using Moy > Convert fo Symbol. ) making suse "%

We need to have access to this component if we want to change any of its properties.

Picture Scroller Properties

You can control the following aspects of the scrolling picture:

Parameter(s) Description

shift increment X & This says how fast to scroll the image. You can set a different speed
Y for horizontal (X) scrolling as compared with vertical (Y) scrolling.
border width X & Y This says how wide or tall the region should be on the sides of the

picture that should trigger scrolling. For example, if your visual area is
640x480, and you set the X border with to 100, if the cursor comes
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within 100 pixels of the right or left side, the picture will start to scroll.

start position X & Y A number between 0 and 100 indicating where to start the visual in
the view. You can control the horizontal (X) position separate from the
vertical (Y) position. Values of 50 and 50 mean to start viewing at the
center of the image. Values of X = 0, Y = 100 mean start viewing on
the left bottom of the image.

Show Text Cues A true or false value saying whether or not to show the text cues (text
boxes) when scrolling is allowed. By default, this is set to false. When
a picture can be scrolled in a direction, a text cue box appears. You
can set the text using other parameters.

Set Text Cues If you choose to display text cues, you can set the text you want to
appear in the boxes. There are four boxes, by default they are labelled
Look Left, Look Right, Look Up, and Look Down.

view clip You enter the movie clip instance name here of the movie clip you
want to scroll.

Changing Scroller Property Values

To change the Picture Scroller properties, you need to select the Picture Scroller then open the
Properties panel (Window > Properties). You will then see a table in which you can set the
properties, described above:

| start X % & start Y %: what-oartofthe Ir.;laae

W properties  Parameters

Component | =
o
| <Instance Name= || jstart X %6 50
- ' fstart ¥ 96 |50
R Tzl Show Text Cues? true
.| 640.0° |%: 0.0 ST R el
& W‘ 5L | |Look Left Text |Look Left
H:| 480.0 |v:| 0.0 Look Right Text [Look Right
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Chapter 7
360 (degree) Panorama Scroller

If you have a special lens to take a 360-degree panorama photograph, such as one from www.0-
360.com, you can use the 360 Panorama Scroller to let viewers spin around to view the panorama.
Behind the scenes, the component duplicates the image to permit a seamless view. Currently, the
panorama scroller does not do perspective correction, so the image will appear bulbous. However,
even with that distortion, viewers may appreciate the ability to see completely around them in 360
degrees, and the view can be very useful for training.

The 360 Panorama Scroller component lets you decide how much of the visual to show in one
screen-full, and provides an easy way for viewers to pan across the whole 360 degrees to simulate
looking left, right, up, or down (depending on how much of the image is not visible at once).

To make creating 360 degree panoramas as easy as possible, we have provided a template you can
use to base your visual on. Once you gain comfort with the Flash authoring environment, you can
configure the panorama in different ways, such as scroll rate, border sensitivity, initial view position,
and several others.

For consistency, you configure the 360 Panorama Scroller exactly as you would for the Picture
Scroller.
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Chapter 8
Picture Navigation

Part of the simulation experience involves letting participants move about the scene as they would if
they were actually there. You can simulate the navigation if you are using PowerPoint to sequence
the visuals--just make one slide for each view, and make buttons to take you from one to the next
based on the direction chosen. If you are using HTML pages to sequence the visuals, you can do the
same with links embedded in the HTML page. However, both of these options require an attention
shift from the visual at hand, and are unable to handle the navigation naturally if you are using a
scrolling picture.

We have addressed this situation by providing a Flash extension (the Navigation Arrow, picture in
the Components panel below) that lets you specify a file to load if the viewer clicks on it. You can
rotate, transform, modify, or even replace the arrow completely with a graphic of your choice. This
arrow can sit on top of a standard picture or within a scrolling picture (regular or 360). In this way,
viewers click on the arrow in the direction they want to move, without having to shift their focus
away from the visual itself, and Flash loads the corresponding visual you have set.

P,

i w Components =
= @ CommandSinm N

360 Degree Panorama Scroller

e
(ERS

inset backward btn
inset down btn
inset forward btn
inset left btn

inset right btn

inset up btn

u [afsfayafafa};

Navigation &rrom

Picture Scroller

oL

set CommandsSim file path

Navigation Arrow and set CommandSim file
path are the two elements used to add
navigation to your visuals

Using the Navigation Arrow is simple -- open the Components panel and drag a token from the
panel to the Stage. Right-click on the arrow and choose the option "Free Transform" to scale or
rotate it to the desired size and orientation:
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When the black boxes appear along the edge, move close to (but not on) a corner and a circle with
an arrow will appear. Clicking and dragging at this point will rotate the arrow. Putting your cursor on
a corner and clicking-and-dragging will enlarge or shrink the arrow.

When you are done, open the Properties panel (Window > Properties), and choose the Parameters
tab:

ik file to load Side D
show label ryLabelInstance

rice Marne =

1 x;|38.4
1 '-,-';I 169.2

Type in the name of the visual you want to load when the viewer clicks on the arrow.

If you want to reveal a movie clip, such as a label, when the cursor moves over the navigation
arrow, and hide the clip when the cursor moves away, enter the movie clip instance name in the
slot marked show label.

Important: By default, the arrow looks for the visuals in the current folder, i.e., if you do not use
the file path component described in the next section.
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Advanced: To Change Where the Arrow Looks for Visuals

If you do not want to put your visuals in the current folder, you have to tell the arrow where to
look. This has to be a full location specification, for example, C:\My Visuals\Owner\... (and so
on).

We have provided a component called set CommandSim file path (see the topmost picture on
this page and you will see this component right underneath the Picture Scroller component). If
you drag-and-drop one of these tokens on your Stage, then open the Properties panel, you will see
there is one property, "path to files":
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¥ Properties | Fikers  Parameters

| E'" Companent [path 1o fias C|/Comenandsim/

~ W 730 X 539.8
?_ H: 16,6 |yl 18.0

This property gives the location of your visuals. Follow the pattern given by the default value, and
give the full location specification, including the drive letter. The navigation arrow(s) will see this
token when the movie is running and look in that folder for the visual. While you see it during
authoring, you will not see the file path component when you run your movie because it hides itself
automatically.

Note: when you change the location, it applies to all visuals for the current Flash file and any others
you link to using the arrow navigation.

Important: if you want to reference files in the same folder, use the set CommandSim file path
tool, but clear the path to files (clear the value out of that space). When the system sees this, it
looks in the current folder for the files, instead of the specified path.
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Chapter 9
Using Flash Movies in Microsoft PowerPoint

Scenes built with Fire Instructor can be used in Microsoft PowerPoint® presentations without
modification. There are two ways to insert a Flash movie (.SWF file) into PowerPoint.

The distribution includes a video that walks you through the process of embedding Flash movies into
PowerPoint using the GlobFX plug-in.

Method 1

We recommend using the GlobFX "Swiff Point Player 2.0" plug-in, which is a FREE plug-in for
Microsoft PowerPoint that enables easy insertion of Flash movie clips (.SWF files) into your
PowerPoint presentation. The installation file is included in the distribution, under the name
"SwiffPoint20.exe."

Once you have installed the plug-in, it puts a new menu item in the Insert menu of PowerPoint. The
menu item reads "Insert Flash Movie...". Once you select the SWF movie, PowerPoint loads the file
and you can then size and position it as desired.

If you choose to use the "Swiff Point Player 2.0" plug-in, it must be installed on any computer used
to view your completed PowerPoint file in presentation mode. The plug-in is FREE and may be
installed on as many computers as you like. You may get more information about the plug-in from
the GlobFX web site.

Method 2

The second method to use Flash movies in PowerPoint uses Adobe's ActiveX Flash player. This
method is not as intuitive or easy to use, but it offers the advantage of full control over the Flash
movie, and the people to whom you give your PowerPoint presentation do not need any additional
plug-in's other than Flash. If you need specific control of the Flash player during your presentation
(e.g. auto playback, looping, quality, etc.), you will have to use this method.

A detailed description of how to insert a Flash movie clip (.SWF file) into PowerPoint using the
Adobe ActiveX component can be found in the Adobe Flash TechNote "Using Flash movies in
PowerPoint 2000," or on this website: www.FlashGeek.com. The same method also works in later
versions of PowerPoint.
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Chapter 10
Scenario Creation Process

This page describes an overall process for the mechanics of developing your simulation. It may be
handy to print this page out and use it as a guide when you are developing your simulations.

Important: We recommend that you practice first with adding effects and transitions, such as what
is described in the CS Effects Quick Start page and the CS Transition Quick Start page before
getting into defining states. The process described in this section is useful when you need to create
more elaborate scenarios, such as those spanning multiple locations and multiple fire conditions.

How Long Does it Take to Create a Scenario?: While you can make a simple scenario (a single
location with few changing fire conditions) within an hour, we have found that scenarios of
moderate complexity (6-8 locations, 3-5 states) can take 1 to 3 days to complete (counting
everything: planning, photography, production, testing, etc.). In spite of their claims, this time is
comparable to scenario creation with supposed "simpler" systems.

Step 1. Planning the training objectives. Scenarios can take a few hours or several weeks to
produce. If you have not clearly identified what you want to accomplish with the scenario (training
objectives) you are making and how you will measure its success, you can never know if the effort
you will make is worth the time invested. If you want to make a quick-and-dirty mock-up, you don't
need much planning, but think realistically about what you need to accomplish given the amount of
time you want to spend. You can always come back and add more if you find what you have
produced needs to be extended.

Step 2. Listing the different locations. How many locations (perspectives) do you want to give
to your audience? In producing a multi-location scenario, think about what are the meaningfully
different locations. You can certainly take pictures 10-15 feet from one another, but you will end up
with a lot of work and most shots will not be meaningfully-different from other shots. Think about
which location and angles get you the most coverage for the aspects of the simulation you are
making. If you find that you want a wide-angle shot, you can use our panorama component to let
the user scroll across the scene.

Step 3. Listing the different states. A "state" is a description of a possible configuration of
smoke and fire for a given scenario. For example, you may have a "no smoke" state, a "wispy
smoke" state, an "incipient" state, and a "fully-involved" state, or anywhere in between. For a house
fire, you might have different states for how the fire has progressed from one section of the house
to another. Think hard about how many different fire conditions ("states") you need to show, since
you will need to produce visuals for each state. As in Step 2, think about the meaningfully-different
states, not all possible variations at minute detail.

Step 4. Create a simulation opening screen. If your simulation has more than one location and
more than one state, you'll want to create an opening screen that sets the state to its starting
value. Your opening screen might give information about the scenario, or might be a picture from
your apparatus as the student is approaching the scene. You will drop a CS State Manager token
into this screen, set the starting state number, and indicate in the interface RESET TO STATE. See
the section on CS State Manager about how to do this.

Step 5. Start with the first location. Create a new Flash file and load (import) the background
picture.

Step 6. Create the states for this location. If you only have one location, you do not need to
make different states using CS State Manager -- you can accomplish what you need using the CS
Transition tool. If you do have multiple locations, drag-and-drop a CS State Manager token into
your file, one for each state of your simulation. Select each instance and, through its interface
(Window > Component Inspector), set its state number, how you will trigger the state, specific
keystroke, etc.

What you will do in the next steps is to place the smoke and fire (CS Effects, or any other movie
clip), and tell each smoke and fire generator how to transition (CS Transition) among the different
states you've created.

CommandSim Fire: Instructor Edition, v1.5 95



Tip: It is a good idea to place these tokens on a new layer so you can find them quickly if you lose
track of where you have placed them.

Step 7. Place the smoke, fire, and other effects/animations in the first location. Drop into
the scene whatever smoke and fire effects you want. For each effect you want to control via a
transition, make sure to give it a unique instance name. You set the instance name by selecting the
effect, opening the Properties panel, and entering the name (no spaces or puctuation) into the box
labeled "<Instance Name>". This gives the effect a name you can refer to when you tell it how to
transition among the different fire conditions.

Tip: It is a good idea to place these tokens each on their own layer, and name the layer, so you can
selectively show or hide them.

Step 8. Create the effect transitions for each states. This is the tricky part. You need to lay out
which effects change on which state changes. If you think about the states you articulated in Step
3, you can group the changes that need to be made by state. For each state, create a transition by
dropping a CS Transition token on the Stage and specify which effect instance it addresses (a single
transition can specify multiple targets by separating the effect instance name by a comma, as in
"smokel, smoke2, smoke3" (no double quotation marks), etc. Since each transition addresses one
or more effects, you might have more than one transition for a state. For example, in early stages
of the fire, you may want to hide the smoke conditions in some extension of the building. Therefore,
you will need a transition that HIDES the smoke effect for that state. Please see the CS Transition
section of this manual for information about different types of transitions.

For each of the transitions, we suggest making them trigger on a keystroke while you are testing
your first location.

Step 9. Test the location for each state. Iterate by adding new transitions, testing, and seeing if
the results are what you are trying to accomplish.

Step 10. Add navigation to the location, if desired. Before you add navigation to the Flash
movie, you will need to decide how you will distribute the files.

= Distribute via PowerPoint slides: Create a slide for each location and create
buttons in PowerPoint to jump to the appropriate slide. You cannot place a PowerPoint
button on top of the Flash movie, so you will need to reserve space on the sides or top of
the Flash movie to place and label your button(s).

= Distribute via PowerPoint on a single slide, or distribute through a single
web page: You can use the Navigation Arrow (described in the section on Picture
Navigation) to indicate what other files to load when the viewer clicks on the arrow. You
can also change the graphic to be anything you want (text, shapes, invisible until roll-
over, etc.). The arrow is a regular Flash button, so you can change it as you would for
any Flash button. We used the navigation arrow in the example at the beginning of this
section. This example source file is located in the Samples folder in the distribution.

Step 11. Create the next location, if you have one. If you are making multiple locations, you
can create a new Flash file and bring in the next picture, then copy and paste all the transitions,
states, effects, and movie clips from the first movie directly into the second (and subsequent)
movies. Alternatively, just use File > Save As... in your first movie to save it as your new location,
then swap out the background image and adjust the effects, clips, masks, etc. for the new position.

Step 12. Repeat steps 7-11 as necessary.
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Chapter 11 Video Tutorials

The following video tutorials are located on the distribution CD in the videos folder. The samples are
in the Samples folder on the distribution CD:

1. Introduction to Flash Elements (15:36)
. Name: IntroToFlash
. Contents: Templates / New File, Using Panels, Tools / Layout, Stage, Timeline,
Frames-per-second / Stage size,File Import, Resizing / Selecting, Aligning / Align tool,
Layers, Locking, Properties, Components, Placing CS Effects, Component Inspector,
Changing Properties, Testing Movie, Publishing Movie
. Sample: firstSmokeMovie
2. Accessing Help (02:23)
- Name: gettingHelp
. Contents: Distribution CD, Inside Flash, Web Discussion Board
3. Intro to Using CS Effects (20:10)

L) Name: UsingCSEffects

= Contents: Placing CS Effects, Naming instances, USE / EDIT / SHARE panels,
discussion board

- Sample: introCSEffects
4. Intro to Using CS Transition
. Name: UsingCSTransition

. Contents: Placing CS Transition, Naming instances, START / END / PARAMETERS
panels, CS Effects effect code, Fade-in / Fade-out / Reset transitions

- Samples: firstTransition, introCSTransition, simpleTrans

5. Masking Basics for Creating Dimensionality in Your Scenes

- Name: IntroToMasking
. Contents: Layers, Drawing tools, Masking
" Sample: maskSmoke, introToMaskSmoke

6. Making a Panoramic Image using Templates (10:49)

. Name: IntroToPanos
= Contents: picture scroller, 360 panoramas, adjusting scroll parameters
- Sample: firstScroller, first360

7. Creating States and Multiple Locations
®= Name: IntroToStateMgr

=  Contents: CSEffects, CSTransition, CSStateManager

= Sample. firstStateManager, State Examples/
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Chapter 12
Support and Feedback

We are dedicated to helping you get results with CommandSim Fire. We have an online learning
community for you to ask questions and share information with us and other customers, as well as
an online knowledgebase of information.

We highly encourage our customers to send us examples of their work to post in our picture gallery
area.

In the event you are unable to find a solution to your problem on our web site, you may contact
Technical Support via email at support@CommandSim.com. Technical support is also available by
phone, but we appreciate if you check the knowledgebase before calling.

If you are sending email to Technical Support, please include the following information in your
email:

e Your product serial number of maintenance contract number
e  Your operating system version

e Your version of Adobe Flash (for example, CS5, CS4, etc.)

Email: support@CommandSim.com
24-hour Web http://support.CommandSim.com
Support:

Community Learning http://community.commandsim.com
Phone Support Toll Free (888) 511-2452

Hours: M-F 9A-5P EST Outside US: +1 (215) 627-8146
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Chapter 13 CommandSim Fire Instructor Edition End User License
Agreement ("Agreement")

This license agreement governs CommandSim Fire: Instructor edition ("Software").
By the act of downloading and/or using this software you enter into the terms of this
binding contract between you ("you" or "User") and CommandSim. If you do not
agree with the terms of this license, choose the "Decline" button when prompted
with the Agreement and exit the download or installation of CommandSim.
Installation of the Software constitutes acceptance of the terms of this License
Agreement.

Grant of License: Subject to the terms and conditions of this Agreement,
CommandSim hereby grants you a limited, nonexclusive license to install and use
the object code version of the Software, a copy of which is provided herewith, on a
single personal computer.

Limitations: The Software is licensed, not sold, to you. You must retain all copyright
and related notices of CommandSim's ownership and other rights in the Software in
the product, labeling and documentation provided. Furthermore, you may not: (a)
modify, translate, de-compile, reverse engineer, disassemble or otherwise decode
the Software; (b) copy any of the Software other than as reasonably required for
your own personal use of the Software in accordance with this Agreement; or (c)
sublicense, sell, rent, lend, transfer, post, transmit, distribute or otherwise make the
Software available to anyone else, except that you may permanently transfer the
Software and accompanying materials provided you retain no copies and the
recipient agrees to the terms of this Agreement.

Trademarks: You acknowledge that CommandSim Fire and related logos and designs
are trademarks of CommandSim, and that no rights in such trademarks are granted
to you by this Agreement.

Support: CommandSim reserves the right to modify the Software from time to time
without obligation to notify you, or any other person or organization of such revision
or change.

Third Party Licenses: Certain images and components of this software are provided
under license. These images and/or components may be copied, modified and
incorporated into materials for personal or for internal company use and in
advertising and promotional materials for you or your clients. You are not permitted
to use the images and/or components, or any portions of the images and/or
components, in any other way. Furthermore, you may not use the images and/or
components in any manner which is defamatory, pornographic or otherwise violates
any applicable laws. You may not make copies, either digital or printed, of the
images or components for the purpose of re-licensing or reselling the image and/or
components (whether separately or in combination with other images and/or
components) or for any other purpose except those expressly set forth above.

Limitation of Liability: IN NO EVENT WILL COMMANDSIM BE LIABLE FOR ANY
DAMAGES, INCLUDING LOSS OF DATA, LOST OPPORTUNITY OR PROFITS, COST OF
COVER OR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, DIRECT OR INDIRECT
DAMAGES ARISING FROM OR RELATING TO THE USE OF THE SOFTWARE, HOWEVER
CAUSED ON ANY THEORY OF LIABILITY. THIS LIMITATION WILL APPLY EVEN IF
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COMMANDSIM HAS BEEN ADVISED OR GIVEN NOTICE OF THE POSSIBILITY OF
SUCH DAMAGE. THE ENTIRE RISK AS TO THE USE OF THE SOFTWARE IS ASSUMED
BY THE USER. BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR
LIMITATION OF LIABILITY FOR CERTAIN INCIDENTAL, CONSEQUENTIAL OR OTHER
DAMAGES, THIS LIMITATION MAY NOT APPLY TO YOU.

Disclaimer of Warranty: TO THE EXTENT PERMITTED BY APPLICABLE LAW ALL
CommandSim SOFTWARE, INCLUDING THE IMAGES AND/OR COMPONENTS, IS
PROVIDED "AS IS" AND WITHOUT EXPRESS OR IMPLIED WARRANTY OF ANY KIND
BY EITHER COMMANDSIM OR ANYONE ELSE WHO HAS BEEN INVOLVED IN THE
CREATION, PRODUCTION OR DELIVERY OF SUCH SOFTWARE, INCLUDING BUT NOT
LIMITED TO ANY IMPLIED WARRANTY OF MERCHANTABILITY, NONINFRINGEMENT
OR FITNESS FOR A PARTICULAR PURPOSE. NO COVENANTS, WARRANTIES OR
INDEMNITIES OF ANY KIND ARE GRANTED BY COMMANDSIM TO THE USER.

Termination: If you do not accept the terms of this license, you agree to destroy all
copies of the Software in your possession and control.

Government Rights: If used or acquired by the Government, the Government
acknowledges that (a) the Software constitutes "commercial computer software" or
"commercial computer software documentation" for purposes of 48 C.F.R. 12.212
and 48 C.F.R. 227.7202-3, as applicable and (b) the Government's rights are limited
to those specifically granted to you pursuant to this License. The
contractor/manufacturer is CommandSim, PO Box 63684, Philadelphia, PA, USA.

Export Control Obligations: You will not export or re-export any Licensed Software in
violation of any law, regulation, order or other governmental requirement (including,
without limitation, the U.S. Export Administration Act, regulations of the Department
of Commerce and other export controls of the U.S.). You shall, at your own
expense, promptly obtain and arrange for the maintenance of all non-U.S.A.
government approvals, if any, and comply with all applicable local laws and
regulations as may be necessary for performance under this Agreement.

Copyright © 2004-10 CommandSim. All rights reserved.
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